Difference between the Huanyang HY & GT VFD

I’ve built my system with a 2.2 KW Huanyang VFD and spindle instead of a router but I ended up purchasing GT series VFD instead of the HY series discussed in the YouTube videos I’ve found.

I wouldn’t have thought it would make a big difference but, clearly, the VFD setup is different. The issue I’m having is with the RS485 comm setup. With the GT series VFD I’ve selected the comm setup, from page 74 of the manual (you can find a PDF of the GT manual at https://www.automationtechnologiesinc.com/wp-content/uploads/downloads/2018/08/GT-series-manual.pdf), is as follows:

  1. PC.01 (Local Address) = 1
  2. PC.01 (Baud rate selection) = 3 (9600BPS)
  3. PC.02 (Data Format) = 0 (RTU, 1 start bit, 8 data bits. no parity check, 1 stop bit)
  4. Within the Onefinity SW I set the tool type to Huanyang
  5. Set the Max spin to 24000
  6. Set the Bus-ID to 1, the baud to 9600 and the parity to None
  7. Net Result – No Connection??

I’m probably missing something, most likely, or maybe the Onefinity code is setup for the HY series exclusively?

Oh, one other thing: the comm hookup on the GT VFD is 485+ & 485- instead of RS+ & RS-. I’m pretty sure it’s the same thing and that it’s not significant though?

If you have any insights, I’d sure appreciate hearing from you.

Thanks in advance for your help.

I expect you are right that it shouldnt make any difference.

What you really need is a person on the forum who has the same VFD up and running with respect to setting up the manual configuration in the onefinity controller and the corresponding configuration in the VFD .

I had trouble setiing my VFD up

Things to check:

  • connectivity from the vfd to breakout board.
  • make sure the breakout board is fully engaging with the controller.
  • then methodically read the buildbotics manual and the vfd manual, try out combinations of setting and record what you did and the results.

from what i have seen in the forums it is typical to have to set frequency, current and voltage settings in the vfd. You dont have them listed above.

Try swapping rs+/rs-

See also:

And many other youtube and forum posts.

Mr VFD @Aiph5u seems to be away from the forums at the moment. He answered many peoples questions. Theres also facebook.

1 Like

Did you get your VFD working. i just got a GT Series and have it running with Modbus.

I used the Custom VFD from the pull down instead of Huanyang. I think the Huanyang shownb is for the HY model.

I used the same setting you show above with Pin 13 going to 485+ and pin 14 going to 485-.

In addition to the settings you show on the VFD I also made the following changes.
P0.021 - 2 (Run Command from Communication)
P0.07 - 7 (Frequency from Remote Communication)

In the Onefinity tool menu with custom VFD selected then press the customize button and input the register data. In the Huanyang Manual the numbers are in Hexadecimal but you need input regular decimal into the chart. If am posting properly my settings are shown on the pic below. Yours may be different so confirm everything for your own machine. I am by no means an expert so I could be giving horrible advice.

Did you get this resolved? I just set mine up and it works. I noticed theres some items you didnt set on the controller.