Elite USB or not to USB

After a frustrating week of pleading with my Elite to NOT lose contact with my USB drive, I have come to the conclusion that it is either the cable, or the USB sub board within the controller that is the evil culprit. No amount of pleading, wishful thinking, or politically correct vailed threats have worked so far.
However, even though it is nowhere to be found in the manual or the official site information, it appears that if you open the controller door, and insert the USB drive directly into the main board, the Elite will operate as one would expect it should when inserting into the intended USB port.
Don’t be fooled by the “intended” use USB port on the bottom of the controller, it’s really not there for a functional reason, it’s more of an optional feature that may or may not work depending on how many stickers and pin-wheels you have on the rest of the machine.
Just saying.

Move the USB extension to the port shown above with the red key to make sure it’s the cable assembly and not the port.

No offense to anyone, I was simply being sarcastic in my above writing. I can’t remember who, but someone else on here was having the same issue a while back, and from the collective response, a reasonable solution wasn’t given…. I just posted the solution.

Yeah, it’s pretty straight forward and a lot of people have already stuck USB extensions onto the other port and dangled them outside the case. I was just giving you a suggestion in case you wanted to check to see if it was the cable itself.

I noticed on mine it’s pretty easy to knock the small connector off the USB board attached to the panel, so for anyone else, that being loose could be something to check.

1 Like

All good, I got the job done tonight… Thanks for stepping up.
I’ll mess with the machine some more in the morning…

1 Like

Masso is aware of this usb issue and tracking it.

If you experience this issue, please create a ticket with masso here:

I’ve come to the conclusion also that the external port is not to spec. After failed jobs and other issues I found an old USB stick that fits very tight and walla, USB doesn’t disappear and probing works now without snapping bits.

The stick Onefinity packed with my unit is very tight.

I’m getting a weird vibe typing that word. Like saying “moist.”

Thanks for stepping up Support Leader

I think that’s about all most of us really want, someone to acknowledge there is a real issue and try to resolve it. These machines are not cheap, and ya, sometimes cheap parts bring an otherwise great machine to it’s knees. I’m sure I can make my own USB input and cable that far exceeds what came with the machine. BUT when I’m in the middle of a job, and my machine fails, that puts me behind and makes me look bad to my customers… that’s not good. If I can’t make excuses… then… well, I’ll stop there for the faint of heart…

I’m not blaming anyone for inferior issues. I just want a solution and move on…

They have. Masso (the creator, maintainer, and supplier of the controller), is tracking the issue. Please create a ticket with them. They do not monitor our forums (so no need to post any more here). Creating a ticket with them is exactly how to get a resolution you are looking for.

Hey Support Leader

Thanks for the information on your last post. I followed your instructions and created a ticket with Masso. They are sending a replacement cable… Thanks again for your direction.

Also… I’m trying to find the function to edit/ update my post in the “for sale” section. I would have sent this message directly, but I can’t find a “direct message” setting to a user. Thanks again!


follow up… Onefinity sent me my new cable about a week ago and finally got around to install it today. pretty straight forward.


after - hardwired vs plug

did a couple test with a video that i won’t bore everyone with, but the end results are this.

  1. the USB stick that came with the masso/Onefinity would still disconnect if i moved the usb stick, but way more than i was doing before - final note on this - that usb stick is just very pore quality and if still being shipped with the new machines, just toss it and use something else.

  2. all other usb sticks i have and tested with no disconnect issues whatsoever. i could originally get these to disconnect by touching them or moving them slightly… no matter what i did they did not disconnect. win.

a couple additional things to note for those going to replace their cable.

  1. you will need to cut and replace a small zip tie - i happened to have them already, but if not pick some up.

  2. the one i received when i screwed in the holder for the USB port seemed slightly different size and after screwing it down it was impossible to insert a usb stick. removed, tested. was perfect. reinstalled and no bueno. way too tight. my solution was to cut a heavy piece of paper to put in between the screws and the usb board that way it wouldn’t ‘squish’ the USB port. worked like a champ and now works perfect.

really appreciate both Masso and @OnefinityCNC taking care of this so fast! every interaction with either just reassures i made the right call with my purchase.