Firmware Update 1.2 Beta (12/5/22) (Outdated Firmware)

I thank goodness never ever upgraded to anything beyond 1.09 but i do rather frequently have a problen with selectin any file that i have to scroll down to. to get around this i frequently put an a or a b in front of the file name so it is on top cause sometimes it simply will not scroll down. at first i tried reloading it several times and that worked once in a while, I do not know if it is the controller’s / firmware problem or my non onefinity monitor. but it is not bad enough to make me change anything

1 Like

What we expect to be the final version of 1.2 has just been uploaded. ( upgrade package file). If no bugs are found, we expect to release 1.2 to the world as the latest firmware this week.


Does this latest beta update for v1.2 firmware include the the VFD config selection for the PwnCNC spindles?


This is directly answered in the first post on this thread.

1 Like

It does not. We’re hoping to place it into the next firmware (will likely be a quick release).

1 Like

Initial test of 1.2.0 looks good to me. I did the full sdcard flash method to upgrade from 1.1.1.

Wi-Fi and HY spindle settings worked as expected.
Screen “upside-down” setting works nicely too.
USB gamepad worked as expected. (I’m using unsupported Google Stadia USB controller so I have to tweak a config file to get Z axis control on the right-stick.

Be sure to follow step #11 of the sd image flash instructions to reset the defaults to your specific machine size.

As a bonus, I cleaned some sawdust out of my controller enclosure while it was open to access the sdcard!

I also then upgraded to the bbctrl-1.2.0-z-fix (1).tar.bz2 firmware version and that fixed the issue with selecting the newly uploaded file via the web interface. edit: nevermind. that still works or doesn’t work intermittently.

Anything else specific you need tested?


I read above the web interface file upload not being selected is expected, but none-the-less i did some more testing. It appears that auto-selection of the newly uploaded .ngc works fine except for when the currently selected file is the top one in the list. Deleting that specific first file doesn’t fix it. Selecting any other file except the first one before uploading a new one makes auto-select after upload work as expected. There is no error output in the browser javascript debug console.

hope this helps! please let me know if there is a more appropriate place to discuss debugging. github, etc… Thanks!

Thanks for this. Also lol: “As a bonus, I cleaned some sawdust out of my controller enclosure while it was open to access the sdcard!”


Thanks !! already updated to the latest version,

Can a json backup from 1.0.9 be applied to 1.1.2?

yes you can do that with json.

Can we PLEASE put the date in the filename so we know which files are the newest? is there an update to 1.2 BETA other than the initial file?


Release candidates have just been updated. 1/27/23
Unless anyone finds any final bugs, these will be the public release versions releasing in a few days.

@PwnCNC VFD configurations will not make it into this version. We will be releasing a ‘hotfix’ patch once we finalize the configuration for it in the near future.


okay i loaded 1.2.1 final and the bug where you load a .NGC file and then load another (doesn’t matter how many) it does not auto switch to the file just loaded. this has been documented in the forums already with video and honestly can cause a crash or worse if the operator is not paying attention.

also, upon loading and turning on my onefinity wireless controller it stated user pressed e-stop. which i didn’t. i could not reproduce at this time.

hope your reading this.


another note on 1.2.1 final - not a huge issue but the touch screen is using 24 hour time, but 12 hour when i log in via network with a browser. i dont see where this can be changed. i prefer 12 hour


@OnefinityCNC - can you please look into this? I have documented with a video above and will not be able to upgrade firmware unless this is fixed.

I have never had this issue until this beta firmware.

We’re investigating.

Can you post a video of this issue (and the file your loading) ?

1 Like

Hi @ahandeman can you please help us with the video and file to replicate the issue on our end. Thanks for understanding. We will be looking into it as a priority.

1 Like

Can you post a video of your issue?

1 Like