Gcode from Carbide C on MacBook to USB

Hi guys! I’m new here and its my first time to get my hands on a CNC. Ive been doing things using hand power tools in the past and I just got my OF yesterday. I created files from Carbide C and saved the Gcode on Basic Gcode PP but I can’t seem to save the Gcode in a USB in proper format, mine is always just saving on Unix Executable format and OF Proc cannot read it. Any idea on what can I do? I’m running CC Build 514 Free Ed. On Mac OS High Sierra atm. Do I need to shift to Vectric Pro and MS?

Appreciate any help. Thanks!

Hi Ricky … Format your USB drive in FAT32 format then copy gcode to USB … you should be good to go.

When you setup Carbide Create use the GRBL post processor to save your gcode.

hi Dave thanks for the info, but I have it formatted already to FAT 32 and even reformatted it multi times also tried ExFaT but to no avail it still transfering as Unix exe file instead of regular text format. I can view the code on d Mac just fine but when I transfer to USB it changes format :frowning: I did the PP in Basic, grbl and shapepoko its same result

Ricky … does the file have a .nc extension after the filename. Also change the filename to something simple such as sample, it could possibly be that the way you have named the file the controller is seeing as a Unix file.

Try it and let me know how you get on. btw: Update your Carbide Create to the latest version which I believe is currently Build 520.

Hi Dave… theres no .nc extension. I have tried shortening the name but still wont save. I have reformatted my USB to Mac OS and managed saved my file on the USB on textedit.app. I will try it on the PP today when I get to my shop. Keep you posted. Thank you.

Carbide Create saves it’s native files as .c2d format. But the gcode file (grbl) should have a .nc file extension.

Hi Dave… I have tried almost everything. The OS format saves the gcode on txt.app in the usb cannot be read when plugged in OF controller. Even the vector file when I transfer to USB is automatically converted to unix exe, but on my mac I can see the c2d ext. the gcode file on mac doesnt show any extension. I will ask Apple and Cc and if nothing else I guess I need to buy myself a MS

Thanks for your time appreciate it.

In the Mac finder go to preferences/Advanced and tick ‘Show all filename extensions’.

Hi Dave… yes it was on “ all filename extensions” when I checked it

Sounds like you are trying to put your gcode file in the wrong place (directory). That’s probably why the system is seeing as a Unix executable file rather than a gcode file.

Can you see the directory structure when go to transfer the file to the controller?

using CC under the toolpath menu I choose a file with ext .c2d, then at the bottom of that page there is just a button “Save GCode”, when I click this will take me to a popup menu to save as, If I save on mac internally it will save as textedit.app extension (i see this if i click the info portion of the file), but if I try to save it externally in a USB, it changes into unix exe., the same is true if I save the .c2d file in external usb drive it will also come out as unix exe.

The CC im using never generate .nc in the mac but rather text edit only for the gcode and .c2d for the cad

What is it (design) that you want to cut on the machine?

I think I know what you are doing wrong.

Hi Dave… While waiting for my OF since January this year, I have done a lot of designs on CC since it is a simple program using my Macbook, all designs are 2D cuts for my previously done manually products.

From what you have suggested, I did some study and I think my fork resource on mac has some problem. I got another laptop running on MS today and tried to transfer some designs I already did on my Mac. The mac now outputs files with .nc extension but still becomes Unix exe as soon as transferred on USB.

Initially it loaded as Unix on USB from Mac, but as soon as I plug the Usb in the laptop running on MS, the MS system opened up a replicate file in the USB stick along with the other unreadable unix exe files but the replicate file is a readable .nc format. I have checked the gcode in text format and it looks good. I will try it in my OF controller hopefully by tomorrow afternoon. And oh I tried saving the c2d from mac as well on the MS laptop via usb and it loaded on the MS.

I tried other designs from Mac and they all loaded on the MS laptop So now I have transferred on MS most of the designs that I have done in d Mac and have generated GCode in MS then transferred to a USB stick. I will have to use MS this time. In long term Im thinking between Vectric pro and fusion 360. I know its a more sophisticated software than CC. Meantime I will run what I can using CC on MS.

I hope the file I have is good in the OF now. Will update you.

Thank you for your kind assistance and encouragement.

Warmest Regards

Hi Ricky … If you are on Facebook can you send me a link to your page so that we can exchange email addresses then I can walk you thru the steps using CC.

Hey Ricky,

When you go to save the G code in CC you have to add the .nc after the file name or it will save it as a text file.


Thanks Larry, yes when I tried adding the .nc extension when I save the gcode the mac started to recognise it as .nc and added them automatically the next time.