Help - Skipping X axis on a 3D finishing carve

I’m not sure what to call this but it seems that the X axis is slipping and only for this file. Can anyone tell me what I’m doing wrong?

I created 4 toolpaths to cut a bowl. Two on the top side, and two on the bottom flipped side including one 3D roughing and one 3D finishing toolpath. Simple.

I cut the rough toolpath with a 1/4" end mill and that went completely fine, but when I ran the finishing toolpath with a 1/2" ball nose, I noticed it started making strange noises, like it was stuck or something. I quickly hit the emergency shut off so as not to harm the machine, and noticed it was cutting the cencentric circles but it moved… It was offset now.

After rebooting the CNC, I re-ran the toolpath in the air without bit and it did the same thing. Any idea as to what is causing this? I’m able to cut circles with another toolpath after this one, no problem…but this was circular and a 3D toolpath which I haven’t tried to remake yet. Is it my machine or the controller? Any help or suggestions are welcome.

Since I can’t see how/where to add files, I’ve created a video on YouTube with a couple of images and a part of the air run. You can hear it, it sounds like the machine is banging into something but there’s nothing anywhere near the entire machine.


It could be a number of things that are causing the slip but it sounds like a loose coupler in either the x or y axis.

1 Like

Thank you I’ll check them. But I’ve also run a few more toolpaths since then without issue.