Joystick commands delayed / over sending

Hello 1F!
I have recently noticed, specifically after a few tool changes and ‘Z Probe’ functions, that my joystick gets a bit irritable. What I mean is that sometimes it doesn’t send (or it isn’t processed by the controller properly) the movements. I can cycle through the different speed settings, and sometimes it comes back and operates. In other cases, like Z up and down movements, it will send “too many” Z up commands and throw off the Z0.
Example: after a carve, and needing to swap out bits, my normal routine is to turn off the router, raise the Z slider, pull off the dust boot, switch bits, move to a good flat place to ‘probe z’, raise the bit again, put the dust boot back on, then start the router, and push play.
Where I run into issues:

  • ‘Z down’ to get the bit closer to the touch probe, With the probe set to ‘normal speed’, I will push down on the joystick quickly and it will just keep pushing down. This has happened a couple of times now. Thankfully, I don’t have any broken bits / damaged carves because of this.
  • On an X or Y move, it goes until it hits the soft limit. This is more rare for me, but it has still happened.
  • ‘Z Up’ (as mentioned above) it will raise the router on the Z slider, then ‘hop’ a few times before stopping. This causes my Z slider to lose its reference. It is trying to go beyond its physical limit.

Usually, it is at this time I take a photo of my current X, Y settings and reboot the controller. While this isn’t horrible, it is a delay, it does require some additional work, and is concerning from a safety perspective. While using the touchscreen, I do not see the same issue.

Make sure the dongle is seated property and change the battery and see if that makes a difference.

Checked both. I reseated it the dongle, and the batteries are new. It is sporadic at best… so not something I can easily replicate. I have just learned to push ‘up’ on the Z controller instead of down. =)

1 Like

Are you aware that the buttons on the right side of the joystick control the amount of movement. For instance the ‘A’ button only moves the controller in very small increments?

1 Like

I am. My normal course of action is to hit the yellow button, wait a second, then hit the red button, wait a second, then begin moving. I am aware of the blue and green buttons and their movement as well, but yellow and red are where I live. =)
The thing I am seeing is almost more like a buffering or an incorrect signal. If it is the latter example here, then it is most probable that the red button is where the problem lies. I think it is more likely the issue is with some sort of buffering.
The best examples I can give to support those are:

  • depress the red button
  • depress and hold the Z down joystick
  • Movement is slightly (less than a second) delayed. This is where I think the joystick is sending, rapidly, the move commands and since the controller hasn’t yet processed it, they are queuing up.
  • Z slider begins to move down
  • release the Z joystick
  • Z slider continues to move down until it either cannot move any further (physical obstruction, bit pushing against the work piece) or soft limit stopping the slider (programmatic limit)

Now if this is because the joystick has sent (numbers for explanation, not actual) 10 ‘G0Z-0.5’ commands instead of 1.
Or if the joystick sent ‘G0Z-500’ is unknown to me. I guess it would be cool if there were a way to see (maybe in a log file, I will investigate this, or through the software) what is being sent it would certainly help.

Using the joypad doesn’t send g code command to move in increments. I don’t experience the issue you are describing when using the joypad to jog the machine, it starts and stops as I move the controls regardless of the yellow, red, green, blue button I’ve pressed. Are you using the officially supported controller? I’ve seen where people have had difficulty with other controllers.

Yup. Came from 1F, in one of the 3 boxes.

That’s odd. Only suggestion I would make is to feather the controls as you move them and begin slowing down before you get to the intended point.

I have done that also.
I am curious what the range is for the controller (joystick) to the Controller (brain box). Since it is a dongle, there is line of sight. So, I would think that anything less than about 10’ should be fine. I am usually about 4’-5’ away at most anyway.
There have been times when I pushed the Z Up once, and it tried to send the Z Slider through the roof (not quickly, just persistent that it could go further) shrug Just be careful I guess.

Mine works from 10 feet away with no issues. It’s worth noting that they operate in the 2.4Ghz frequency range which is the same as wifi, microwave ovens and many other wireless devices, it is plausible you have something in the environment that is causing interference. It shouldn’t be related to wifi as it will be more graceful and attempt to avoid the interference. I’ve seen mention of people using a wired joypad (not the official one) successfully might be worth a try.


I am having this issue now, were you able to find a resolution?

A suggestion in the gamepad manual is to try the dongle
in another USB port and reboot the machine.

1 Like

I have found on mine I can run the yellow across the table then hit the green and everything drops to a crawl. So far this has worked well. I flattened my whole spoil board doing this…

1 Like