JTech 44W Laser Firing Inconsistently at Low Power

Hi all,

This discussion is in regards to the JTech 44W laser on a Onefinity Journeyman. My Onefinity is on version 1.0.9. The signal cable from my Onefinity to the laser controller is shielded and grounded.

Shown below is a material test on slate. If you look at the 2%-4% power columns you’ll notice a line on the edge of each box, and the remainder of the box isn’t filled in as dark. From what I can gather, when first turned on after the last S0 command, the laser immediately fires at a higher power than what was called for, and then reduces power to its set value.

I was able to prove that this is the issue by opening up the GCode file and replacing every “S0” with “S1” so the laser doesn’t completely turn off. I’m not sure if this is a laser controller issue or a Onefinity issue, or if the 44W laser struggles to operate at low power levels.

Material test with S0:

Material test with S1 (Still a few spots, but significantly better):

Having thought I had figured this out (albeit in a way that’s inconvenient), I ran into a new issue while lasering a photo onto a 12"x8" piece of slate. Referencing below, you can see that the circled portions (and more) have what appear to be streaks in them. Looking closer at the image, you can see that this is actually from the laser firing at a higher power than it should, causing areas with larger, whiter burns. I thought this may be from a poor signal to the controller, but the cable I used has excellent connectivity and is shielded and grounded. Not really sure how to go about this. The photos below don’t show the streaks that well, but in person the streaks are unfortunately very visible.

Slate with Streaks:

Slate with Streaks:

Lightburn Preview:

Lightburn Settings:

Any advice would be much appreciated!!


I’ve also tried power cycling the system, re-generating and re-uploading the code, and printing different segments. In the photo below you can see that the three middle sections have the streaks, whereas the bottom sections do not. The only major difference is that the middle segments have significantly more area to burn. Is it possible that the laser controller can’t keep up with 125mm/sec (295IPM) speeds?

1 Like


With the help of Jay from JTech’s customer support we were able to figure out the issue(s).

Dithering images requires the laser to turn on and off repeatedly at a very high rate. My feed rate of 125mm/sec (300IPM) is too fast for image dithering. 40mm/sec (100IPM) is the sweet spot for dithering.

My original tool setting used “Laser (J Tech, ect)”.

Jay suggested that I switch to “PWM Spindle” and play around with the “pqm-freq” setting, making sure to not surpass a value of 3000.

I did a few tests with frequencies ranging from 1750 - 3000, finding a sweet spot at 2000 (this may differ for you). I also played around with the rapid-auto-off and dynamic power settings - these don’t effect the image as much but disabling them did seem to help a little bit.

Having said this, I still occasionally get higher power pulses when not expected. This is completely fixed if you replace all “S0” values with “S1” in the .gc file as mentioned above (I still make sure to keep “G1 S0” at the end of the code so the tool power is set to zero when the process is complete). The command S0 seems to shut the laser off, where S1 is low enough to not engrave the material and it keeps the laser on.





New on bottom:

Huge shoutout to Jay for helping me out with this!!


Interesting! Very cool the laser works on slate! Thanks for sharing your results.

I was analyzing the PWM output with an oscilloscope the other day while hooking up a laser. I noted the JTech tool preset appears to use 1kHz pwm-freq, so it’s interesting the ideal setting for you landed on is twice that frequency. I also noticed when I went to full power (S1000 M3) the oscope couldn’t detect a PWM frequency anymore, not sure if that’s good or not, it did seem to cut fine at full power, but i notice the pws-max-duty here is 99.99%, and perhaps turning that down a few points might help me out too. I look forward to exploring these options you’ve highlighted. Thanks!

edit. added photos for fun.

1 Like

Slate is my favorite material to work with! You can purchase 4"x4" slate coasters on Amazon. These are super fun to play with!

Thats very interesting what you found with your oscilloscope, thanks for sharing! I also found it interesting that doubling the frequency helped so much. I’m definitely not an expert when it comes to understanding how PWM works, but my assumption is that doubling the frequency would essentially double the speed in which the controller receives commands. I could be incorrect with this assumption though.

Thanks for sharing your experience!!


Yeah, I’m no expert either, but I think the diode laser may actually pulse at whatever the control frequency is set at, or maybe some ratio of that frequency. It would stand to reason that if the pulses happen at a higher frequency, they could be closer together even when the machine is moving quickly. A neat test to try to confirm might be to lower the PWM frequency and see if lines start to appear perforated instead of solid at higher feedrates. Or, perhaps there are use cases where lower frequencies are better too, i don’t know! :smiley:

1 Like

Thats a pretty neat idea!! I’ll play around with that when I have some scrap material again!

44W here too. When i fire off the laser to see where it’s aimed with M3S10 and then I try to jog, the laser goes out. Would changing PWM be a possible solution do you guys think?