Masso link, MyWorkshop WiFi connect not working

The Easy install “Masso link” and wifi connection to “My Workshop” was not so easy. There is not much discussion with my specific problem, or as it turned out to be, problems, on the Masso or 1F forum, so I thought I would post the resolution steps for my issue here in the event someone else is also having similar problems.

Everything is up and working now. It was a medusa not just a one headed viper. So if connectivity is not so easy as they say on the Masso web site perhaps you have one or more of these issues.


“My workshop” would not connect. it showed my machine but is indicated “offline” while the machine was running. The MassoLink app would not connect. Not possible to WiFi transfer G Code.

  1. Brand new Masso had V5.07, I thought. When someone on the Masso forum suggested I check the version, it was 5.06. Downloaded and upgraded to V5.07 still not working. Masso link would not connect to machine. Machine was connected to “My Workshop” but was still “offline”; as expected I could not wifi transfer g code. My Masso not using the resident wifi network would not connect either.

  2. in the trouble shooting process I discovered that the Windows 11 firewall was not allowing Masso in. There was a flash screen asking if I wanted to allow Masso during the app install process. I indicated yes, I wanted it to be allowed , but learned the setting was not changed. Masso was added to the watchlist of apps in the Widows system but the boxes to allow access were not checked. Manually going into Windows and changing the security settings allowed some connectivity between Masso link and my CNC but it still was not working correctly.

  3. the WiFi network I used had a base router and an extension point. I have several devices that connected preferentially to the extension point. All of them work well but not the Masso. The Masso would show connected to the Wifi just fine but would not connect to Masso web site. I know, what is up with that? I unplugged the extension router and the Masso connected. When I powered down the Masso, plugged in the extension and turned the machine on it would not connect. Unplugged the extension, exited the WiFi on the Masso and then tried to reconnect and it did so, very quickly. I stopped being lazy and moved the main router to a central location in my home and removed the extension point altogether. Now everything connects. Now I can monitor my machine and Masso Link connects but, I had a timeout error on file transfer. That part was still not working

  4. I was using an empty flash drive, with 64MB of space, plugged into the Masso. I formatted the drive. installed Masso link as directed and no go. It would get to 24% of the file transferred and time out. The error stated “Masso not responding”. I had a newer flash drive, also empty, with 128MB of space. It has better file transfer rates per the product info than the first one I had. The files transferred successfully. I am in the hunt for a faster drive as even the newer one is a year or two old. It takes about 4 minutes to transfer 8MB of G code.

So, now it all works. Be mindful that a seemingly simple problem may have many causes. I hope this helps someone should they have a similar problem.


It’s my understanding that the max thumb drive capacity is 32gb. You can reformat larger drives, and I tried that, but it was very frustrating and inconsistent. Once I tried a new 32gb drive my problems were solved. Just something to consider.


The max filesystem size of a FAT32 partition is 32GB. The flash drive connected to a Masso must be formatted FAT32 and use MBR, not GPT.

1 Like

Yep, that’s exactly right. So, are we in agreement that, say, a 64gb cannot be used, even if it’s formatted FAT32 and uses MBR?

I would think that you should be able to use a 64gb USB with an MBR formatted 32GB FAT32 Partition but i havent tried yet.

1 Like

The 64gb drive works with manual transfer but not WiFi.