My spindle won't turn on?

Hi All,

I have a problem with my spindle not turning on. It on a Elite Journeyman with a Huanyang 2.2KW VFD and spindle, and I use Vcarve Pro as my software. I bought a spoilboard pattern off of Etsy and the machine worked fine to cut out all the part. But when I built my first job and tried to cut it out the spindle wouldn’t turn on. I can run it manually from the Masso controller, but it won’t came on when I try to run any of my G-code. Not sure if I missed a step some where, I’ve checked that there’s a speed setup for the bits I’m using, I’m using the Onefinity Masso Inches post processor, I also tried the the Masso ARC Inches as well. Not sure if I have to add a line of code to turn it on or what. Just wondering if anyone has any ideas of what to check or if I have to add some code? I haven’t been able to find anything helpful online.


Hey Jesse,

if you enter “S12000 M3” into the Manual Data Interface (MDI) the spindle turns on?
But if you run a program, it does not turn on? Do you find occurrences of M3 in your g-code? Did you make sure your Tool number is not “0”?

1 Like

Did you change the VFD jumper from the VR to VI position?

1 Like

I bet you didn’t select the Huanyang VFD + Spindle in the tool menu. I have to do this on my Buildbotics controller when I switch between laser and spindle.

1 Like