Okay, I don't have any idea what to do now

I got my Elite set up, don’t know what I did or didn’t do or what I’m suppose to do. My brand new Foreman and frustration arrived Wednesday. Upon powering on, I get the two flashing alarms. I do the emergency switch, all good. Double tap homing: Z20 goes up, slider goes slowly to the left and gets to left Y rail where it stops, and there isn’t a back off I noticed, the motor on the Left Y rail is flashing red and green back and forth.
I shut of power, pulled the plug manually moved the slider toward center, and tried again. I get same results, of course. I have tried to jog the xyz axis with these results. I have to be in continuous for it to work at all. Manually moved the slider to the center position. Going to right, it does not move. Moving to the left seems to work good, try and go back right works but stops at the center position.
Trying to move X forward and the left side starts to move, the right does not. I’m not sure what to do. Any ideas?

Try removing the cover on the alarming motor and checking that the connectors are in place.

My Foreman got banged around pretty good while being shipped. I had to replace connectors on 3 of the motors, in addition to having to bend a bunch of aluminum pieces back to their intended shapes.


1 Like

Thanks Dan, all my motors came packed in a separate box. I installed both Y rail motors and the one on the X rail. I have checked for loose connections, but all seems good. I’m at a loss as to what options I have since I have zero experience with any CNC. I was hoping I could just put it together, plug it in and “Yea, it would work.” If there is anyone who lives in or near Kansas, and provides lessons, I’m game and looking for a “Personal CNC Elite trainer.” Any ideas, and help is greatly appreciated.

What did Support say? They’re typically all over this kind of problem. Not like them to leave you without a fix.

Howdy Jim,
I emailed them this morning actually, and didn’t expect to hear anything until Monday. The support team contacted me within a short time, had me check the DIP switches on the 4 stepper motors. The B1 stepper (the one on the RT Y Rail) had the switches in the incorrect positions. I put the switches in the UP position, and tried again. It homed the first time and then would only go half way across the X axis and halfway toward the back. I recycled power, tried it again and all worked. I’ll try my first air carve tomorrow and hope all is good. Thanks for asking Jim.


@Bub glad they got you up and running. I can imagine the anxiety over a brand new machine not working right. :call_me_hand:t3:

Oh yes, it was very stressful. I just hope I can figure out what I’m doing now. I know the machine is capable of doing far more than I will ever know how to have it do. I’m still waiting on my PWN 2.2k water cooled spindle, they are on back order. Daniel, from PWNCNC is giving me a refund of around $94 buck, which is totally awesome for a buisness to do that without even having to. So far, I’m very impressed with the Onefinity support and the buisness ethics of both 1F and PWNNCN


I got the same one this spring. The most time consuming part of the install was swapping the 65mm for the 80mm spindle mount…which has nothing to do with pwncnc’s spindle! I love it. While I have yet to cut aluminum on it, I went with water cooled so there is no chance of a stray chip getting inside and causing a short…something that made me sweat each time I did it with the makita.

Make some chips! Have fun!

1 Like

I ordered the 2.2 K water cooled spindle as well, they have a minor delay in shipping them, but if all goes well I’ll be receiving it in a week or so.
I just did my first air run using the ELITE test code, all it seemed to work perfectly. Not much else I can do yet, except figure out how to do my spoil board. I’ll start working on that this week.

No, I didn’t ask although it did make me wonder how they tested my machine, made the carve, and all that. I was just glad it was a simple fix.

1 Like