Homing, Please Wait...Forever? (solved, link in comments)

I’m having a homing error that I can’t figure out. I have not made a single cut on my machine yet, so there’s nothing more than a light layer of wood dust in some places from other projects while I’ve been trying to figure this out.

When I home, the machine returns to the correct location, backs off properly, and then just sits there pretty much indefinitely blinking Yellow, asking me to wait. I left it there for about 15 minutes in that state, just continuing to blink, before turning it off. Restarting the machine does not produce any change.

Everything jogs properly (except Z has a weird problem which I’ll get to in a second) except that, while it’s in that homing, please wait mode, X and Z will jog fine, Y will move, but B doesn’t follow.

I just updated my software today from 5.03 to 5.06. I was hoping that would resolved the problem like it did for others, but it didn’t for me. One difference though is that on 5.03 the machine eventually resolved to throw a red Homing Error Alarm. I don’t know why it doesn’t throw that alarm now, nothing but software has changed.

Also installed the Z brake today and my Z seems to be acting up a bit now. It will not lower all the way to the bottom of the Z axis, it leaves a good 1"-1.5" unused. Prior to installing the Z brake, it would travel the whole rail just fine.

I have confirmed that all connections to all motors are plugged in snugly, every wire to those motors is securely connected, and all sensors are being seen by the Masso properly as far as I can tell.

Any help is greatly appreciated, I’m super frustrated.

Machine: Foreman Elite
Software Version: 5.06

Sounds like your B motor is the problem. Is the power light on you B motor on and green? May want to pull the cover off of the motor and make sure that the connectors are plugged in tightly.

B follows Y perfectly except for when it is in this failing to home situation.

Light is green, all wires are tight in their connector, and the connector is as secure as can be in the motor.

Got some help from one of the Facebook Mods and he pointed me in the direction of the default setting .htg file. I uploaded that and the machine home properly now. I guess I must have messed something up along the way, but I haven’t changed much of anything, so I’m not sure what it might have been. Thank you for the help!


Hey Jake,

I’m having a similar problem. Can you please direct me to the file said Facebook moderator shared with you to access .htg file?


That worked! Thank you, Support Leader!