Onefinity Elite not loading Lightburn files for JTech Laser

I have a JTech 24w laser, which appears to be functioning correctly with the Masso Controller. However, when I save a GCode file with Lightburn version 1.4.04 file on a USB flash drive it isn’t being read by the Masso Controller. I put the file in a Lightburn directory on the USB drive. But clicking on that folder doesn’t show any files. I’ve setup my OneFinity JTech Laser selecting the GRBL-M3 option. When I save the files Lightburn gives it a .gc extension. Is that correct for the Masso Controller? If not, what would be the correct file extension?

Do I need to put the files in a different directory on the USB drive?

Any guidance you can give me will be appreciated.

1 Like
  • The “Select Serial/USB and click Next” option does not appear in my Lightburn after I select the GRBL-M3 option. It goes directly to naming the Laser.


Outputting Gcode

While there are many settings that you can use the steps above are the minimum needed to get up and running.

  • Once you have created your project select Save Gcode to output your file.
  • Remove the .gcode at the end of the file name and add .nc and all files from then on will save as .nc files
  • Ensure that you have selected GRBL-M3 (1.1e or earlier) for your device when saving to ensure it outputs the correct Gcode format. This is only a problem if you set up more than one device.
  • Ignore the disconnected message on screen as it only applies when the Laser is connected directly to Lightburn.

Thank you. That, changing .gc to .nc corrected my issue!


1 Like