Issue reading GCode from Lightburn

I have set up Lightburn using the Onefinity provided post processor for X50 Journeyman. When I save the code to USB and load in the machine, I keep getting the same message:

{“code”:400,“message”:“Unable to read file - doesn’t appear to be GCode.”}
The simulation works however I am not able to see any code, just the message.
Wedding Laser Song_line+Fill.ngc (5.0 MB)

I have attempted to save with .ngc extension to no avail. Has anyone reach a solution for this.
Onefinity Controller Firmware is v1.1.2-alpha.01
Using the Lightburn/1F PP - GRBL-M3

I have no issues using the Vcarve PP on my 1F/Jtech 14w setup but would like to switch to lightburn for the improved optimization for longer burns.

your very outdate and alpha firmware would be the first thing to check.
We issued a ‘recall’ a while ago for anyone running 1.0, 1.1, 1.1.2, to completely reflash their OS. Also, alpha firmware should never be run on production machines, especially very outdated alpha.

1.3 is stable and can reflashed here:

1 Like

Thanks for the information on updating the Firmware! I have flashed and now on the recommended 1.3.0

Unfortunately, I am still seeing the same error message. I created another file in LightBurn to see if I still have the same error and each time as soon as the simulation starts I can already see the message.

Try naming the file to something simple (without the weird characters + _ ), like ‘’ or ‘file.gcode’ and see if it runs.

1 Like

I looked at the ngc file you attached and noticed right away it uses “;” to denote a comment line. The LinuxCNC Page seems to show that this usage should be ok - but I have never seen it done before.
Normally comments - even if it is the whole line - are put between “(” and “)”.
This may not be the issue but just suggesting. I would try renaming the file as suggested above first.
After supper I will take it to my machine and try to debug.

Hey Chris,

I use “;” to delimit comments all the time.

I use “;” to delimit comments all the time

Thanks Aiph5u
The fact that I have never seen it just means I don’t get out much.


Hey Ross,

although when input sanitization is properly done during programming, you may use any character in a filename (including newline), often it is not. Therefore usually programmers avoid “+” in filenames, since it is a special character in many environments.

By the way, firmware 1.0.* and 1.1.* were so bad that they were revoked.