Probe Z issue after updating to 1.09

Hello. I’ve been using the Z Probe function for over a year now and I haven’t had any issues until today. I recently updated to 1.09 and today is my first carve since updating. In the past, I was prompted to attach the magnet to the collet and touch the probe to the bit. After I did that, the “continue” button would turn green and I’d be able to continue with the probing.

The difference now is that the “continue” button is always green, and when I click it, the z moves up about 1/4" and then I’m prompted that the probe is done.

I’ve rebooted the controller a few times, and reset the configuration to Woodworker 35. Does anyone have any idea what’s going on?

Thanks, George

Very strange indeed, I’ve been running 1.09 for about 4 months now and never an issue with probing.

Before you hit the “Probe Z” does it look like this:


Or this:


It looks like the bottom one. I just finished my carve, but I had to set Z with the paper method. I’d still like to figure out what’s wrong with the probe though.

When the boxes are green like that the circuit between the probe and the magnet are already complete. if you unplug the probe from the controller do those boxes still remain green? If so you should open a case with Onefinity support, if not you should inspect the probe wiring for a short.

Ok, I just unplugged and plugged it in again, and the problem persists. Here is a video fwiw. Thanks for your help, I’ll send a support ticket tomorrow if I can’t figure it out today.

Out of curiosity, did you upgrade to that PwnCNC spindle at the same time? Having a similar issue over here as well.

1 Like

Yes I only updated to 1.09 when I installed the PWNCNC spindle. I also did the steps in the video you posted and the black + signs turns green when the magnet touches the collet. So according to the video the probe is set up correctly but it’s not functioning correctly.

1 Like

Ok, the grounded spindle is completing the circuit, in effect the probe is wired “backwards” you need to reverse the connections to the magnet and touch plate.


So could I just pop the pins out of the connector and reverse them? Haven’t looked at it yet, but I’ll check if that’s doable.

I gotta say, it’s nice that the machine didn’t just crash into the probe and was intelligent enough to understand that something was … different.

Just go into settings on the controller and change from whatever is currently selected (normally open or normally closed) to the opposite.