Really frustrated (Over / Under toolpath warnings)

One more thing not to do is leave the brushes on when you probe. A slight touch by them misaligns the probe

You lost me here Kjohn. where do you set the postions in the software you create the file with?
today I cant get my z to become error free after homing and loadng the file and setting all xyz zeros with the touch probe its over under no fit
Im tring to do a simple vcarve sign 16x24 and failing miserably lol
Im about to start drinking and i hate alcohol lol
the longer i have the machine the worse its getting lol thats not how it supposed to work is it lol

well I thought i had figured out myself until yesterday. i understand the xy error the one i dont get thats keeping my from running anything now is my z axis. its has me super confused all day.
Ive never had to deal with it giving me errors until now.
So im in here reading watching videos that ive not had to do so yeah i get ya and the frustration.
I have to remember something my grandfather told me once or twice when I was a teenager working on my car. Id get all frustrated mad and all that and hed say brian when you get like that just take time out walk away and calm down and forget it and then come back to it and things will work much better. So I did what he said I quit workin on my car went shot some basketball with some friends for a hr or 2 and when I came back to fix my car I went right back and figured out where I left off and you know what it went together no issues and as I thought about it all i could do was laugh because he was right. sometimes a break is what we need and things will flow much better when we get the right mind set back
Im trying to use that advice he gave me today lol
tomorrow Im gonna whoop this thing and carve my design.
I bet too when I figure out what Ive missed ill be like wow really thats all it was lol
good luck hope you got your surfacing done and are off to making things and learning new things. I spend many hrs each n every day on this just like school or work and i thought i had this part down but No apparently i dont lol and ive done some pretty advanced 3d carves already and today i cant start the machine lol ive had great luck for over 2 weeks until now lol

1 Like

In vcarve when you first start a new file it asks for size of the material you’re starting with. Below that section there is a 5 dot diagram showing with one of the dots highlighted. I believe it defaults to the center one. If you are going to pick up your wood at the lower left corner, you have to select the dot in vcarve that corresponds to that. I hope that makes sense to you. I know my explanations may not be very clear. Lol

yes i do that. I know what your talking about perfectly. thanks for getting back to me. I still cant get my machine to run like this. im putting it up forsale it above me i guess after using it no issues for 2 weeks lol this sucks im here trying to delete everything i have put in the forum
The manufacturer isnt even able to fix it or help they just send me here and to youtube university
they want a barely a beginner to do advanced/expert user things lol you alll have fun i got a dud and stuck with it now
cant sell broken equipment and get anything for it. maybe scrap metal at the salvage yards lol
thanks for your help.

Brian,
That is incorrect. We send you to the faq pages of this forum as your questions have been answered in the FAQ’s. We could copy and past them to your support emails if that’s what you’d prefer. The machine is working as it should, it’s not a dud. :stuck_out_tongue: There’s some user error here.

You’re wanting to ‘factory reset’ the machine, and we’ve included the FAQ with detailed video walkthrough on how to do so. We can’t really get any more detailed than a video walkthough!

1 Like

What is the easiest way to identify the outside edge of the cutting area? I ask because I want to set up a jig on the front left corner to ensure that my starting point is exact EVERY time I run a job. As I understand what you are saying I am outside that cut line?, but when I use the dimensions I have been given in the box at set up, I shouldn’t be outside any cut surface.

I feel like I am missing something crucial and cant for the life of me understand, Is there any optin for me to do a short Zoom call with support to go over a few issues? That would be EXTREMELY helpful!

Hey CNCGeek,

You are just too impatient. A CNC machine is not something you unpack, turn on, and just use like a coffee maker. It’s pretty complicated, and it’s the same for everyone: Until you master it, and understand everything, and can do things that others do, that takes a while. A good while. That is normal.

4 Likes

Santos,
This faq and the included videos will show you (especially the one with v bit making a square)

1 Like

Just curious, what kinda toolpath are you trying to use to surface your waste board? I use pocketing cause it gives you better control with keeping the cutter from trying to go outside your cutting area.

1 Like

Here is the video everyone recommended. I just don’t know If I’m doing something wrong, I am a pretty intelligent individual but I feel like such a moron right now! :joy:
I had followed this video to the letter and still had issues…

For both @Santos76 and @CNCGeek.

I think at this point, what we really need to be able to help is to attempt to reproduce your issues on our own machines. If you can collect the following information into a post, it would allow us to attempt this on our end:

  1. Create and post a simple VCarve project in which the issue appears on your machine. If you are using Aspire, save the file as .crv (not .crv3d) so it can be opened in VCarve.

  2. Generate and post the corresponding gcode file.

  3. Make a note of which machine you own (e.g., Woodworker, Journeyman, etc.).

  4. Make a note of which post processor you are using. Is it the one that comes with Vectric version 11+ or one of the manually installed pps for version <= 10?

  5. If able, create and post a short video detailing the steps you take from power-on of the controller to the error appearing, including any homing and probing.

  6. Save and post a backup of your controller settings (.json) file. To do this, in the controller interface, go to Admin > General > Configuration > Backup.

If you do all of this, I will personally attempt to reproduce your issues. If you prefer to work one-on-one, you can direct message me with the above information. I can’t guarantee I can solve your problem, but I promise to look at everything you provide in detail.

6 Likes

One option is to put in a V Bit and carve a shallow score mark in the wasteboard all the way around the perimeter at the farthest extent of the machine’s reach. You can do a quick program in V Carve or whatever software you prefer, or if you are comfortable with the controls it’s really easy to do with the joystick. Just make sure you lock yourself out of X/Y directions when you only want to move in each one at a time as you go around.

1 Like

Are you still getting over/under errors on the Z height? If so, which holes on your Z Chassis are you mounted to? Some users (depending on their setup) may need to mount the spindle in the lowest position to have enough reach to surface and cut the spoilboard directly with certain bits.

Thank you for your response, I have corrected the issue.

If you’ll overlook the length of this post, these might help you and perhaps some others, even if they are off the topic a little. Trying to figure out the workarea dimensions ties in with the remainder of these common starting troubles. I reported these to the 1Finity team, but through no fault of theirs, the way I worded these previously probably caused them to dismiss my bug report.

In certain scenarios, clicking the ProbeZ test may incorrectly trigger G-code soft-limit exceeded errors when trying to play code. If the z soft limit is exceeded during the internal pre-test, the error dialog can leave the webcode in a state at which it incorrectly reports the same error when ProbingZ again, even if the user has deleted all GCode afterward and loaded new GCode that does not exceed the soft limit in any way.

The internal ProbeZ pre-test currently incorrectly tests against the current z height of the router/spindle before the probe initiates movement, allowing the user to overcome seeing the soft limit error dialog in some cases by moving the z height slightly higher before clicking ProbeZ. Having the bit’s tip closer to the probing plate can push the pre-test into failure mode, which is not related to the probe/router/spindle height hardware limits in any way. [So for you, try starting with a higher z height for your router or spindle before pressing ProbeZ. You can only push it up a certain amount however, as the ProbeZ test will abort if it has to move too far downward to contact the metal plate.] The internal G-Code limit-exceeded pre-test code likely belongs at the beginning of the play button routine instead – something the developers would need to adjust.

ProbeZ can also fail to exit correctly where it displays the ‘don’t forget to put away the magnet’ code path in certain cases during these issues. This will lock the user from having access to moving the motors via the USB game controller. A workaround is to press the +z or -z buttons on the webpage. This will restore gamepad control. The code needs a little rework help there too.

In my early usage days, it wasn’t obvious to me whether I should press Stop, Ok, or Clear in the ‘soft limit exceeded’ dialog when those choices were presented. Sometimes I did not press the Stop button. I don’t know if that was the trigger, but once, I subsequently ended up with my system running a lengthy program of G code that could not be stopped via the standard stop button afterward. I hope the developers will add a fail-safe run=false boolean that is set by the stop button and check that each execution loop to help trap race conditions and other potential bugs.

I’ve also had a stepper motor quietly run continual miniscule steps where moving the USB gamepad controls made no difference.

If an error dialog occurs while a remote 1Finity webpage is open, the two instances – the remote webpage and the machine’s output – will be out of sync when one page’s Stop or Ok(/Clear) button is pressed.

A timeout resulting in Ah Snap can occur when the remote web-based page is open (and inactive) for lengthy period of time. The remote will not display the issue of the loss of connectivity. A reload of the 1Finity ‘base unit’ Ah Snap webpage will then lead to incorrect states. If the programs resynced all activity state, variable states, and any necessary (re)initialization scenarios after an ah-snap, that would help.

When Ah, Snap occurs due to a session timeout, pressing Reload may leave the user in jogging mode and may leave the UI without a delete button for existing GCode.

Running the G-Code and pressing stop midway can result in a condition where the home limit may shift considerably – possibly from a race condition where the user is moving the y-axis immediately via the gamepad after(?) or maybe during(?) the press of stop. More testing is required to identify the cause definitively – that just happened to be what I inadvertently did when I soft-stopped fast y-axis movement mid-travel. I was able to move the router/spindle base further away (from home) but moving it back toward home stopped at the exact same point, so a large shift in the home y-limit had occurred.

Since the Hardware Emergency Stop button will leave the user without Z control if a Makita router bit is deep inside a cut when the button is depressed, the user can get stuck in a potential fire situation. Since the hardware emergency stop button requires a reboot of the entire system to regain control, and the reboot time is significant during that critical time where the user may need to move the spindle or router vertically from a piece, it’s worth a share. Perhaps one quick press of the hardware emergency stop button should act as a software stop (after the bug that allows the standard stop button to be ignored is fixed), and two or more presses or a hold of the hardware emergency stop shuts down the system entirely? Maybe…maybe not, but letting everyone know that the software stop button should be the go-to button in most cases for router users is needed. Reaching in to turn off the Makita may pose the risk of serious injury if the workpiece split or became loose and unstable. Adding an easy-access, appropriate amp-rated switchable power extension for the Makita power cord next to the hardware stop button, or just knowing you should be ready to pull the plug manually in a crisis, and train your mind to do so, might save a limb or a life. Maybe a future design could offers a software-switched outlet on the controller so the hardware emergency stop stops everything?

The YouTube tutorial on ‘setting up the machine and first bootup’ omitted the mention of the twist and pull of the emergency stop button for those that follow those instructions.

I know normally one wouldn’t put all of this together in one post, but I feel it might help everyone to have it all consolidated.

1 Like

CNCGeek just a note when I started this journey I never done this so started watching YouTube for help and found a person that explained the basics in very simple terms, look up “paw paw work shop” or just “paw paw”. when you find his channel ( he is an older gentleman )you will need to look at back vids and find his vids on cnc he is using a xcarve machine, but that doesn’t matter the actual running and programing is the same. Please watch him before giving up completely. I’m still learning this machine and from everything I have seen from other people with other brands this is the best (it does have some problems, but the ease of running once you lean the basics is great).

2 Likes

I love that channel, thank you for the email!

Oh thank you so much. Im no quieter i got it fixed been making things since.
By accident i think i may have stumbled on nice income potential. I showed a cpl of my designs i made to someone i flipped houses for the last 6 years before i retired and they showed them to some of the stores they know and they want really what ive done so far and want me to bring them some to put in their stores to try sell. So that next :laughing:

Machine is fixed
I just need materials now and im off to the races with this thing
Thanks for the information
I will have a look
Thanks again for replying
Its a gorgeous day here in Southern IN
Fantastic weather to be out
Hope you are enjoying the same

2 Likes

Yes its a great machine ive researched them for past 3 yrs and said if i get one this will be the one i get and i did
Kinda wished id waited one more yr to but the larger one but i was excited to get going lol
I love using it
Heres my latest project
Just made from scraps left over from bench material. Good to practice with before moving on to better wood etc

2 Likes