Running programs

Hi all,
I finally received my machine and it’s set up for my first test program. I made a couple small programs in fusion 360 and posted them with the onefinity post they have.
They are .NC extension files which is what I believe the machine needs. I plugged USB into back of controller and went to load programs but nothing shows up. Am I missing a step?

Hey Kevin,

I don’t know if you checked this already, but today USB sticks may be formatted with exFAT

PS: It should say NTFS
PS2: Btw, NTFS and FAT32 are neither partitioning systems nor file types but file systems.

This I doubt. USB 3.0 is backwards compatible by design.
There were rare issues concerning early hardware.

There may however be incompatibility regarding connectors, but when that shows up it’s obvious.

  • USB 3.0 cable can not be used with USB 2.0 terminals because of the additions - USB 3.0 Type B plug are not backward compatible.
  • USB 3.0 cables can be used on USB 2.0 hosts, but then require USB 3.0 end devices.
  • USB 2.0 cables can be used on USB 3.0 hosts.
  • USB 3.0 end devices c a n be connected to USB 2.0 hosts. There may be problems if they consume more than 500 mA of current (USB 3.0 allows up to 900 mA, USB 2.0 only up to 500 mA).
  • USB 2.0 end devices can be connected to USB 3.0 hosts.

The controller contains a Raspberry Pi 3.

Raspberry Pi 3 supports USB 2.0, but as mentioned above, a USB 3.0 device is always backward compatible. A USB 3.0 Memory Stick runs on a USB 2.0 host without a problem. The problem sometimes is another problem: It is that devices larger 32 GB are mostly formatted using exFAT and not FAT32. If your OS version does not support exFAT, reformatting your memory stick is the solution then.

1 Like

I purchased a couple of USB drives that were labeled as 3.0. I see that they are formatted as FAT32. After seeing this post I tried loading a toolpath and taking it out to the OneFinity. It shows up when I open the directory. My question is, how do I know whether the USB drives on my computer are 2.0 or 3.0?

Hey Randy,

this is very dependent on your computer and operating system.

I can tell you how it’s done on mine but my os is not widely used

Raspberry Pi Zero, 1, 2 and 3

Known USB Issues
Interoperability with USB 3.0 hubs
There is an issue with USB 3.0 hubs in conjunction with the use of full or low speed devices, including most mice and keyboards. A bug in most USB 3.0 hub hardware means that the models prior to Pi 4 cannot talk to full or low speed devices connected to a USB 3.0 hub.

USB 2.0 high speed devices, including USB 2.0 hubs, operate correctly when connected via a USB 3.0 hub.

Avoid connecting low or full speed devices into a USB 3.0 hub. As a workaround, plug a USB 2.0 hub into the downstream port of the USB 3.0 hub and connect the low speed device, or use a USB 2.0 hub between the Pi and the USB 3.0 hub, then plug low speed devices into the USB 2.0 hub.

Maximum Power Output
As with all computers, the USB ports on the Raspberry Pi supply a limited amount of power. Often problems with USB devices are caused by power issues. To rule out power as the cause of an problem, connect your USB devices to the Raspberry Pi using a powered hub.

Model ........ Max power output of USB ports
-------------+--------------------------------
Pi Zero, 1 ... 500mA per port¹
Pi 2, 3, 4 ... 1200mA total across all ports

1.) For the original Pi 1B the limit is 100mA per port.

1 Like

Hey @Kjohn Kevin,

did you resolve your problem? Did one of the answers here help?

Thanks,

Thank you. Yes it is resolved.
Sorry for late reply. Still learning how to navigate this forum and learning what to look for to know when I get feedback.

Hey Kevin,
thanks for your reply. If I may ask, what was your solution?

I was trying to use a usb 3.0.
It was also 128 gb
I switched to an older usb stick and it worked fine. It was a 16 gig one