Stuck on Screen Popup

Hi guys,
I just received my machine and in the process of setting it up. I am trying to surface my spoilboard and have created a file in Vcarve Pro. Then i tried to load the file.
Since then i get the message shown on the attached image. There is no way to reset this and every time i reboot it tries to reload this file.
Does anyone have any suggestions?
Any guidance is much appreciated.

Welcome. I am new too and haven’t gotten my machine. Were you able to analyze the gcode?

Try this on a PC and see what it does. I would be interested in the results too. Might happen to me later. Sorry, I can’t give a definitive answer.

No, i have not yet. That is the next thing i want to do. The bigger problem now is that i can’t do anything with the Onefinity since i cannot get rid of this popup. It wont accept any touch commands.

You may be able to connect to the controller from another machine (http://onefinity.local) and delete the file. Alternately you could ssh to it and delete the file.

I tried that, but it shows the same screen withe the stuck popup. Do you know in which directory the file is located?
Thanks for your suggestion.

I don’t but there was a post somewhere on here that had the location. May be able to do a search/locate of the filename

The uploaded files are stored in /var/lib/bbctrl/upload

1 Like

Could you post the gcode file? I’d like to try to reproduce this on my machine, maybe figure out what’s going wrong.

Thanks Dave, here is the file. I believe i had the work area set to big for the machine.Surfacing.ngc (2.0 KB)

Weird, can’t reproduce the behavior you were seeing on my machine. Running the 1.0.7b3, same as you.

If you hit something like this again, make sure to post.

I am still fighting with this. I was able to call up a terminal window from the gui, but cannot seem to locate the bbctrl directory. I can drill in up to /var/lib/ but then there is no bbctrl directory. Not very familiar with the PI.

Thank you Dave, that did it. I navigated to the upload folder and deleted the file. After refreshing the GUI by hitting ctrl R everything works fine again.
Thank you so much for the outstanding support.
I will have to learn Linux commands better.


I got this exact same thing today and I don’t quite understand the fix above. Any way it can be dummied down a bit for me? I only have my laptop, no touch pad. They didn’t have any when mine was sent so I have to wait a month or so. Hoping I can get this working soon

I had just flattened my wasteboard also but it did it with no issues. Not sure what I did to cause this.

Hi Ethan,
When the controller starts up it loads the last file that was open which it has previously stored in internal memory. In my case that file was corrupted. That us why the popup got stuck. The way to fix this is to delete that file from memory.
Thus means that you have to get to the command prompt of the operating system.
Im am not very familiar with Linux (which the PI us based on, so tech support guided me through the process.
Maybe they can chime in and help you out.
If not I could try to put some instructions together for you. However, if you erase the wrong files by mistake there us no way to reverse that which might screw up the controller further.
I hope this helps.

If you email, they’ll help you get this straightened out.

Ah I see. Well I appreciate the response and for trying to help! I emailed onefinity support so hopefully they’ll get back to me in the next day or so. Thanks!

Thanks David, emailed them tonight :+1:t3: Hopefully get my first real project started this weekend

Had to bring my controller inside to a tv, hook up with an hdmi and follow their instructions to fix this. Fairly straight forward but a pain. I hope this is patched. Lasted a couple hours and just got this same issue again. On a good note, my first cnc project went well and i haven’t snapped any bits yet lol

I got this same message tonight after I was running the file for gridlines on my spoil board. I had the depth set too shallow and wanted to redo the program to cut deeper. I am new to this and the only way I knew how to stop the program was to hit the red button. I wasn’t concerned because the bit in the new program would be going over the sane path, just deeper.

Well when I created the new g-code I got this error. I researched and saw that it was because the last file was stored in memory. So I re-ran the original file in it’s entirety knowing I would go back over it with a deeper path. It completed the original file and when I went to run the new g-code with the deeper path I still get this message I originally received. How do I fix this so I can run new files??