Touch probe signals the motors to run away from the touch plate

Hi guys, finally got my OF running, however my OF Touch probe seems to be malfunctioning, connectivity is good based on the test but during probing sequence the bit is running away from the touch plate on all xyz. Im doing manual work piece zero for now but I want use the probe… any suggestions how to make it probe?

Hello Ricky,

2 things I’d suggest, first one is make sure your Firmware is updated to .8 and the second is try shutting down the controller and rebooting. I know my OF has done that 2-3 times over the year I’ve had it and a reboot seems to fix it every time.

Hope that helps,

Hi Alex… thanks. I did my update to .8 and did several reboots but still I cant probe properly.

Thanks for trying that Ricky, Did you double check your wiring to be sure each plug is into its correct port? also id your machine facing the standard direction plugs forward or did you reverse it to be backwards? If you did you need to swap the cables as noted in the forum assembly section.

If that all checks out you probably need to send a note to


Hi Alex… yes I did check the connectors, I did not reverse the y rail motors and my OF works fine except for some occasional Y axis losing its position at the end of the program and that reverse motion when probing. Im just guessing the circuit of the Touch probe is connected reversely :frowning: I sent message already to OFsupport. Thanks Alex

I would also contact @charleyntexas as I believe he makes/supplies the probe. I am sure he can help troubleshoot as well.

Are you homing your machine when you start it up before trying to Probe? If not then give that a try before you try to probe the touch plate. If you still have the same problem, try zeroing out all three axis before you start probing. To be sure they are all at zero, go to the MDI line and type the command below and send it to your machine::

G92 X0; G92 Y0; G92 Z0

As far as polarity of the wiring for your touch plate, it doesn’t matter which is positive and which is negative. It will work either way, unless your have a spindle that is grounded. The Makita palm router is not grounded at the bit so wire polarity is irrelevant.

One other thing to check is the direction of travel for each axis. Standing at the front of your machine (Y Axis motors at the opposite end and X axis motor on your right). Home your machine, then manually jog it so the spindle near the center of your machine in the X and Y axis and the spindle is at about midway point. Remove any bit that is in the collet for now.

Next , copy the following code and paste it into a blank Text file using Windows Notepad and save it as something like “Direction Test.txt”. Then load the file and run it just as if it were a carving file. You spindle will not come on. What you should see happen is your spindle will raise up about 1/2 inch and then the machine will move in a 4 inch square pattern in a counter clockwise direction. If it does not move in counter clockwise direction then let me know which way each leg of the square is moving.

    G91 G1 Z.0.5 F15
    G1 Z-0.75 F10
    G1 X4.000 F30
    G1 Y4.000 F30
    G1 X -4.000 F30
    G1 Y -4.000 F30
    G90 G0 Z0

Hi Charley… thanks for the support. You got me at Grounding the Spindle body. I removed the grounding of the spindle and its now probing normal. Can I ground my spindle direct to earth then? will give it a try dedicated ground for spindle.

Hi @charleyntexas,
I am having the same issue, but before I try all the MDI tests, I thought I would ask if the fact I DID reverse my Y rails is a cause or otherwise requires changes in the setup, etc.

Appreciate it!

Did you install a Spindle?

Just wanted to ping back in here from my earlier post. Has anyone with an issue full updated their Firmware? There was an issue in one of the older versions that I was having the same issue with. Once I updated the firmware and RESET my configuration it has never happened again. Updating Firmware alone will not do it, you have to also Reset/Forget your configuration.


Hi @rickyacruz
No spindle…using the Makita.

Hi @MindOfMcClure
I manually updated the firmware when I first got the unit…but not since. I’m on v1.0.8

I’ve been out of pocket for a bit so not sure what the very latest version is.

Hey Roger,

That is the most current version, OF is working on 1.0.9 I anticipate should be getting close to release. But 1.0.8 was the one that solved my issue so if you are on .8 it must be something else. Not sure if you are one of the folks that leaves their controller on all the time, but if you do you may want to do a full shutdown and restart as well.


Hi Alex,
No…I shut down when not in use.
Just tried it again this morning after trying a suggestion from OF Support (un-reverse >> re-reverse the check boxes) Still wants to move into the +XY direction to find the probe edges. Again, Z works just fine.

OK.mea culpa time. It was pilot error. Sorry for the false alarm and thx for the assist.