Touch Probe seeing contact with no contact after doing a spindle upgrade (solved, reset config)

RESOLVED. Onefinity got back to me after I went back to the router. They suggested a reset of the software configuration. I backed up my config and I did a reset and it worked. Restored my old config and it broke again. So I’m going to have to go through the reset config and manual re-configure it. Hopefully it continues to work.

Hello,

I recently upgraded my woodworker X-50 to a 220V 80 mm spindle. Proper VFD cable and shielded signal cables. As part of that I also grounded the Y rails and the spindle is grounded. I’m still on 1.0.9.

I went to use the touch probe for the first time since doing the upgrade and found it is behaving very weirdly. Rather than moving towards the probe at a slow pace, it move away about 1mm and decides it is done with that axis and moves to the next one.

More detailed:

Press Home XYZ button. Tells me to touch the probe to the bit. I get green button. After selecting the .25" bit size, it starts moving the spindle. This all seems normal. No unexpected Green button due to backwards wiring, it comes on when expected.

It moves Z up ~1 mm, then moves rapidly right to clear the block and then down and instead of coming back slowly to touch the block it moves FURTHER right ~1 mm. Then it moves back (Y) to clear the block and across X, then it moves FURTHER away ~1 mm then announces it is done. It registers that as the new Zero.

It is like it is registering a contact with no movement and the ~1mm move is the retraction after.

I have tried rebooting.

I’m seeing 3.266V between the probe plate (+ lead) and the ground (- lead) (whether I use the magnet or not since the spindle is now grounded). Ohm test shows an open circuit. Magnet to ground is 0 ohms. Thinking it is a potential ground problem (since that is what I effectively changed) I unplugged the VFD and the grounds I added. That didn’t change anything. So the only ground on the system now is the one coming in to the Onefinity controller. All circuits share a common ground at the house panel. I tested resistance between the 220V ground and 110V ground and got 0 ohms.

If I do a manual zero and the machine seems to work fine. I did a couple simple Vcarve lettering with no issue.

I’ve searched the community forum and don’t believe I came across the same.

I’ve tried Onefinity support, they consider this an unsupported spindle issue. I could try going back to the router to test but the switch between 65mm and 80mm mount is a bit of a pain.

Update:
Actually, to remove the possibility of it being the spindle, I went back and REMOVED the spindle and put the router in its place. I changed the Tool setting back to Makita. I removed the 25pin breakout that has a connection to the VFD so that there’s no connection now to the VFD or spindle. I also turned off support for my E-stop physical switch since without the 25 pin breakout it was now reporting as an Open circuit and E-Stop would engage. So I am back to a very basic Onefinity configuration. Controller, wired joystick, touch probe & ethernet is all that is connected. I don’t use a display, I use a laptop on the network.

I now have to use the magnet again on the collet. Machine is still behaving the same. Looking closely I see there is actually 2 movements. There’s a small movement that seems like it should have been going the other direction to find the probe, then there’s the retraction movement.

Any suggestions/solutions?

Thanks.

Hey Atroz,

I should be in bed already but saw your post which of course makes me think.

Can you measure constantly the ‘logical high’ voltage on the probe, especially in the moment when the machine wants to move towards the probe and the erratic probe finding happens? Preferably with an analog multimeter (pointer instrument) if you have one, since with a digital it’s not sure if you can see very short variations of voltage.

Another thought is, is the behaviour the same if you remove the touch probe cable from controller and touch probe, and you wire the touch probe to pin 22 of the 25-pin I/O port?

Good night!

1 Like

See my update. Resolved.

I don’t have an analog multimeter, just digital.

Thanks. Have a good sleep.

Hey Atroz,

interesting. Can you make a diff between your old config and the default config?

Did you by mistake change something on the I/O page?

Good night!

Tried doing a diff of configs. Unfortunately it is a JSON file and it outputs in different order each time making my diff flag just about everything. So I used an eyeball diff instead (Firefox provides a JSON parser) and really can’t find a reason for what happened.

The one I saved was after I changed back to router so there are differences around the tool settings (e.g. PWM for the router vs Huayang spindle). Beyond that some of the motor settings are to more decimal places in the new config which is interesting but, I can’t see that causing what I experienced.

E.g. New (reset):
max-velocity: 10.00000032
max-accel: 750.0017064

Old:
max-velocity: 10
max-accel: 750

I’ve got the spindle back in place and working. Touch probe is back to not needing the magnet as it can get ground from the spindle. Probing works just fine again.

Hey Atroz,

[…]

and, what is so your time for the Z assembly unscrew and change motor mount? :rofl:

[…]

Nice that they did not come to this idea before you disassembled everything :frowning:

Change mount time = 0 seconds.

I realized I had no reason to change the mount, I just removed the spindle and dropped the router in loose. I wasn’t going to spin it up and use it, it just needed to be there for the probing. As there’s no electrical connection between router and mount, it also didn’t have to be held tight. Probing didn’t have to be accurate, it just had to make the right moves so even if the router moved it wouldn’t matter.

1 Like