Trouble installing High Torque Motors (solved, see video)

Hi folks, so I went ahead and purchased the high torque X motors for my Journeyman, today when I tried to swap the motors I found that the wiring harness connector that connects the X motor to the front port is in the middle of the X tube :confused: There doesn’t seem to be any slack to pull the cable out to undo the connector. To make things worse, as I was fiddling with it, the connector came undone so I’m unable to put the old motor back or upgrade to the new one. Has anyone ever had to replace an X axis stepper? The comment here made it sound as if this was just replace and done. - Onefinity is excited to announce the PRO Series - #16 by OnefinityCNC

I have just ordered the same motors to upgrade my X50 Woodworker. I found the following tube vid, so it looks like we have to completely disassemble the CNC to get at the screw under the front foot. I had assumed there was a connector at the back, but obviously not. This is a real bummer and is causing me to rethink the upgrade. Hopefully someone will jump in with another solution.

1 Like

Yep, you need to remove the y axis and remove the rails from the mounting board to get to the screws at the bottom of the feet. Once the motors are replaced, you need to reassemble, check for square and probably re tram. Not a simple “motor replacement” but that is what it is.

1 Like

OK, so I was able to complete this. I’ll try to explain how I did it. Mine’s on a QCW so I removed the QCW mounting bolts on both sides at a time, was able to slide the rails far back enough to get to the screw and remove it. The rest was fairly straight forward once I watched the video you provided. Thanks a ton for that.

Sounds good, I can probably do the same on my table. Great idea😀
My motors arrive late next week.

Also, I didn’t put back those little screws when I reassembled :rofl:

Did you under all four mounting feet and pull the whole assembly forwards or just undo/replace one y rail at a time?

I did one y rail at a time so the whole machine wouldn’t be unstable on the QCW mount. The rail will slide back easily.

Good to know ahead of time .TY

I had problems with that connector that is in the middle of the tube. A terrible design in my mind since you have to completely disassemble the machine to get to it. Part of the problem is that they do a crossover with that connector. But that connector in the middle of the tube is very difficult to service. Hopefully Onefinity will improve the wiring for future designs so it will be easier to service.

Hey Rex,

you don’t have to disassemble it if when building your table, you made a hole in the table exactly where the bolt to release the end cap is :wink:

1 Like

The connector kind of needs to be located inside the tube. Otherwise you would have a lot of extra cable by the stepper. I’m sure anyone who accidentally has something catch on the cable ripping it out of the stepper motor would be even less impressed if 1F didn’t put the connector inside the tube.

They aren’t cheap but I would suggest either a Wadsworth Super Deluxe Mini Ratchet set (very good quality) or a Chapman set. I think Harbor Freight also sells a similar set for even cheaper. You will sill need more room to remove the screw but not as much as you’ll need using an allen wrench.

1 Like

Did my motor upgrade today.
Unbolted one y rail and pulled it forward so the front leg just overhung the front edge of the table enough to get at the screw. Undid the screw on the bottom
Couldn’t remove the plastic plug, so drilled a 1/16” hole into the plastic and put a screw in and was able to pull the plastic plug out.
Removed the old motor and replaced.
Pushed the y rail back to its original mounting position and re attached to the table.
Performed the same procedure on the other y rail.
All is good

1 Like

I couldn’t easily pull on the plug so I just pulled ever so lightly on the wire harness coming from the controller. Mine was loose, just no way to pull on it. A long rod from the other end of the tube would push it out.

Mine were really tight even putting them back in I had to us a block of wood/mallet.