Y2 Rail stuck/hung (solved)

Good morning,

It would appear one of my stepper motors on my X-50 Journeyman has failed during only its second use. While running a small tool path to cut a makeshift dust boot, what I believe is the Y2 motor has seized. I’m concerned as to what damage this has done to the ball screw on both sides as the Y1 motor was of course working properly and competing to move the Y axis against a seized motor. I emailed support this morning to initiate a repair/replacement under warranty. Has anyone else experienced this issue? Thanks.

It’s 99.9% most likely not a stepper motor.
It’s most likely hung/stuck/missing steps. You have not done any damaged to the machine.
Follow this guide: Troubleshooting: Rail is getting hung, stuck, or out of alignment


Thank you for the swift response. Just confirming, you would like me to run through this guide first as a part of moving forward with the warranty inquiry I opened? Making sure I’m following steps correctly since I had also emailed support separately. Thank you, again.

You’re email has already been replied to.

We went through all the steps recommended and the Y axis now travels normally. Full disclosure, there was nearly no dust or debris built up in the ball nut. Perhaps the total equivalent of half a grain of rice in dust was removed from both ends. Again this was it’s second cut so not a lot of opportunity to get gummed up.

Regardless, all of those steps has remedied the issue. On a side note, are those areas that sensitive to have caused the issue and, if so, would you recommend picking up those third party 3d printed covers to protect the screw drive better?

Finally, it appears the Y2 ball screw is a bit off now. I assumed the cleaning and moving of the Y2 side independent of the Y1 side had caused the issue but after turning it back to being even I am still left with quite a bit of space on Y2 after homing the machine. This wasn’t the case prior to the issue this morning. Would you recommend removing all the screws fastening it down and re-squaring the machine or is there another remedy you’d suggest first? Thank you again for your assistance.

loosen the x rail bolts that connect it to the Y.
Turn the controller on and skip homing. Jog in y forward so both gantries gang the front feet and stay flush with the feet. Tighten the x rail. Start cutting.


That did the trick. I’ve corrected the title of this thread. Thank you.

1 Like

One for FAQ immortalisation (needed 20 chars)?

Hey Jason,

since the times of pre-Internet and Internet-based discussion (long before WWW) such as Netmail, BBSs, Usenet, and Mailing Lists, it is good practice to add a “SOLVED” to the subject/topic line.

Further Reading :slight_smile:

“SOLVED” in Onefinitycnc Forum

Hey Aiph5u,

My apologies that my effort to accurately title the nature of my thread was not quite good enough. Thank you for policing this grave oversight and simultaneously providing me one of the most awkwardly passive aggressive replies I’ve ever read since the times of pre-Internet and Internet-based discussions (long before WWW) such as Netmail, BBSs, Usenet, and Mailing Lists. (New users can only provide two links)

I will endeavor to meet or exceed the forum etiquette you have both linked and displayed. :slightly_smiling_face:

1 Like

Hey Jason,

I just realized that nobody welcomed you to the forum.

Jason, welcome to the forum!

Wow. How can pure and emotionless information be interpreted this way? :worried:

My sincere thanks.

For me personally it was the seven links and history of the internet lead in :rofl:

Hey Jason,

yes, seven links in one post from me are a bit few… Hope to get back in shape soon! :slight_smile:


He’s not kidding…and always informative :grin:


He’s German. It’s required :slight_smile: Engineers to the core. :wink:


The above made me :grin:.

Its really tough to get a feel for what folk feel through text messages, also to judge how people will read them. Add to that different upbringings; what a minefield.



So, I just had a similar issue occur. I’m not sure which motor had the issue but it sounded as if the X stepper motor made some audible clicks like it was missing steps. Observing the cut, it appeared the machine had jogged itself out of its known coordinates and was misaligned. It repeated this behavior, missing steps on the same motion again. The coordinates were then clearly out of alignment and it made obvious error when it aggressively collided with the middle stock which was not intended in my toolpath or gcode.

I’m trying to troubleshoot what’s causing the issue with these missed steps and would like any advice you guys may have.

I upgraded the machine to an 80mm spindle and I wasn’t sure if that added mass was causing the behavior. It might be a good idea to upgrade it but I don’t know. Any advise here would be welcomed.

I removed the X axis stepper motor as well as the spindle to remove any unintended weight from the Z axis assembly. The ball screw is very difficult to turn near the center of the machine. However when I bring it a fair distance to the right or left of center, it spins almost effortlessly. Has anyone else experienced this issue?

I am still troubleshooting this currently and will update this thread with any findings. Thank you all for your attention and assistance thus far.

this will have your solution: Troubleshooting: Rail is getting hung, stuck, or out of alignment

1 Like

Yeah, I’ve got it torn down to that level and I’m getting it to track better but I’m just at a loss at how this is occurring this often. The ball screw is practically pristine. This is cut four? The machine is cleaned with a compressor and lubricated between every tool path. The build up of dust is sparse, not even occluding the surface of the metal. I have some of those accessory 3D printed ball screw cleaners coming today so hopefully that will help. I don’t mind the maintenance, I’m just trying make sure this doesn’t happen any longer.

Just for anyone viewing and curious, this was the largest extent of build up on all of the bearing assemblies. The others had even less.