Unable to read file - doesn't appear to be GCode

After updating Vcarve Pro to version 11.503, I am seeing this error when loading Gcode files:

{“message”:“Unable to read file - doesn’t appear to be GCode.”,“code”:400}

Some Forum posts suggest the Post Processor is wrong. I don’t think that changed with the update. All these .crv files worked OK for me before updating Vcarve. Using Notepad++, the .ngc files look like good Gcode to me. Any suggestions on what to look at would be deeply appreciated.

Thank you,
Dave

How about an answer Onefinity, having the same issue. Updated to 1.1.1 last week everything worked ok. This morning it wont read the G Code. FOR ANYTHING.
Can you get this fixed please.
Before you blame it on something else. NOTHING HAS CHANGED ON MY END or V Carves end.
It worked on Friday Sat Sun Mon. But not today.

Email support vs ragging here. Frustrating yes but this is not support.

That said… Post a file here and maybe someone can help with specifics… Both these posts don’t provide enough detail.

I use vcarve… Have not updated to the 11.503 version yet… Use 1.1.1 firmware without issue using previous gcode and newly created gcode.

3 Likes

This post was flagged by the community and is temporarily hidden.

Here is a file that will not load:

Barn+Text_2-All_Text_V_Bit_60.ngc (39.7 KB)

you have special characters in the file name, remove them (like + - and _ )

4 Likes

I renamed the file and it now loads. That appears to be the problem. Thank you.

3 Likes

I’ve been using underscores in my filenames for two years! It’s going to be a headache to change my naming conventions

1 Like

I believe the +is the true culprit as _ is a common pattern for me too

4 Likes