Controller unable to read file

this is killing me ! keep getting this message when loading a file from the network. {“code”:400,“message”:“Unable to read file - doesn’t appear to be GCode.”} . It goes through all the code checks and renders the 3d image and then this message. File is VCarve Vectric Desktop .ngc file 23MB . I just finished running a pocket toolpath using the same postprocessor with no problems. In other posts the size limitation is over 100MB. I deleted all previous paths from memory. I restarted. I shut down and waited a while. controller firmware is 1.08.

Any ideas?

Have you tried re-installing the Vectric post-processor. I installed the one that is linked on this forum and have never had an issue.

I install into ‘mypp’ folder rather than with all the others as it just comes up as the default.

Thanks Dave - worth trying other pp’s. I was also going to try loading from USB rather than network.

I know with Carbide Create for instance, that Onefinity recommend using the GRBL pp … there’s a chance that it might work for you if you have no luck with the USB transfer.

Hey Dave - I tried another PP and it loaded fine. I’m looking my custom PP output and it appears it is corrupting the .ngc file somehow. When I try to open the .ngc file in MSWord, it asks to select the encoding. The other .ngc file from the generic PP did not. Why it did not corrupt the other .ngc files I created is perplexing. I will go back to generic until I can figure it out.

1 Like

Glad you were able to at least get it loaded, mate.

general info for anyone using Vectric VCarve Desktop (and I would assume Pro and Aspire), I found the solution to the above code 400 unable to read file problem. I modified the PP to startup spindle with a delay (thanks to @blaghislain), put in the tape split to split long/large carves, and put in as much info from the file as permitted by the API so I can figure out what I did when I created it the day before - memory is the second thing to go:(. One of the info pieces was [TOOLNAME]. If you look at your tool database you will see that Vectric adds the degree sign to VBit names. Apparently when you create the gcode file with that degree sign you change the encoding of the file so that the 1F controller does not like it. You can test your files with MSWord - when opening if word asks what encoding to use you know it ain’t right. Seems all other text editors don’t care. Solution is to either don’t use [TOOLNAME] or edit out the degree sign. BTW, all tool names have the convention of putting some info into a () pair. This will throw an error when loading the file. You can edit these out in the tool database as well.

1 Like