Waste Board Run Error - Carbide Create

I have tried several different options (recreated the file, ensured all the cables are connected, changed the dimensions and the position of the tool path 0) on my own as well as suggestions that I have seen in a similar post and have still not been able to successfully complete a flattening run. I have run a similar file 5 tines with the outcome is always being the same.

When running the file x is jumping from 10.82 to -32.827. Below are the two files that I used. Any thoughts or guidance you might be able to provide would be helpful.

Video of Jump ==> https://youtu.be/2A63bbDEmnI

Picture of outcome ==>


May 9th, Afternoon Flattening File.c2d (5.8 KB)
May 9th, Afternoon Flattening FileGRBL.nc (1.4 KB)

Brian … Are you running this job from Carbide Create or Vcarve Desktop? It seems to be programmed in Carbide Create but you mention Vcarve desktop in the subject line. What size is the bit you are using to surface the spoilboard? The file shows that your datum is in the centre of the workpiece but the video is showing that it is starting from the front left edge.

Thank you for pointing that out. I am indeed using Carbide Create and updated the subject line to reflect that.

I am using the Amana Tool 45525 (1-1/8 Diameter).

Regarding the starting point, what are you seeing that implies that I am starting from the front left? I am starting from the center and am zeroing at the center. Is there something else that I need to change?

Hi Brian … Sorry, was possible issue with my Carbide Create. However your file showed that you were using a 1/8" tool to surface the spoilboard & it would take ~178 mins to complete instead of 1-1/8" which would only take approx 2 mins. Have attached the file I created just to check if all was OK. Not sure why machine is jumping to those co-ordinates but try my file if you wish & let’s know how you get on. Feel free to adjust feeds/speeds to your liking.

Surfacing File.c2d (5.5 KB)

1 Like

Are you using GRBL as the post processor? If not, you’ll need to.

Also, check your xy zero in the CAD vs your XY zero physically. If you’re using the probe, it will always be bottom left, make sure you CAD matches that.

I am using GRBL as the post processor.

I am not using the probe for this. When you say check xy zero in the CAD vs your XY zero physically, I am assuming that you are referring to the Toolpath Zero which you can see is the center. If you are referring to something else, please let me know.


When you save the G code should it only be 4 lines of code? I ran the file and just the Z adjusted.

Screen Shot 2021-05-19 at 6.59.57 PM

I am not sure if you saw the video, but the attached file runs it is jumping and not completing the run.

Brian … Try this file & see if it runs OK.

Cheers … Dave

Surfacing Project.zip (2.6 KB)

I have also created another version of the attached file this time moving the zeroing point to bottom left. When I ran that the machine moved to the middle. I am not sure that if that is normal behavior or not as this is the only the second file that I am trying to run (first being myers wasteboard (zero at center)). The result was the same.

Thanks. I did try that and the results were the same. I uninstalled and reinstalled Carbide Create if that was the problem. What happens when you create the Code? Are you getting the same results?

Brian … When I recreated the file which I uploaded it showed the correct gcode showing multiple paths in the simulation as you would expect & would take approx 8 mins to complete.

The file shown above is the incorrect version.

Can you send me the Gcode file? I am assuming when you say the above, you are referring to mine. The screen that has the two lines boxes of code were created from your file.

Surfacing Gcode.nc.zip (940 Bytes)

Dave. Thank you very much. I will give it a try/ I would like to get to doing some fun things.

1 Like

That worked great. I now just need to figure out what I was doing wrong. I really appreciate the help.

I think you’re forgetting to select the vector when you’re creating the toolpath. Essentially, the toolpath is empty.

That is exactly what I was doing. I did not realize that you had to select it. While I did not run the file again, the Code results matched the file Dave sent me. Thanks.

1 Like

Glad you are able to get on with some real projects now, Brian … Cheers mate!