X motor alarm (limits)

Good morning,

I recently installed the elite upgrade to my Journeyman. I’m having an issue with the x-axis.

When I jog to the right it seems to stop a few inches short of the limit and gives me an x motor alarm. I’m able to clear it by resetting the E-stop and then I can jog back to the left and home the machine again. However, The X axis will only move about 47in to the right and it will alarm again. I checked the traveling distance in the programming tab for the x-axis and it does show 48.0134in.

I tried setting up a job, loaded it and ran it but again, when it gets to the right of the x-axis it stops the job and alarms again.

Make sense ??

I emailed support and waiting a response :slight_smile:

Did you home the machine first? That’s required upon every boot up for the machine. To jog correctly.

That’s the first thing I did :slight_smile:

Any resolution on this @Whistler? I just upgraded my Journeyman to ELITE this past weekend and I am running in to a similar issue. I have 25+ years of CNC experience on a number of controllers and machines. In my case, it seems that the X axis is stalling near the end of its travel - near the soft limit. If I reboot the MASSO and attempt to HOME, the X axis immediately faults. The only way I can clear the alarm is to turn off the controller and manually turn the ball screw top move the X axis a couple of inches to the left away from the end. When I do this, I can feel that it takes a lot more torque to turn the screw and then it frees up after an inch or so. So this really seems like there is some friction causing a stall. My rails and screw are lubricated and clean. I’ll contact support on this.

I was moving over that far to set my PARK position - something I never did on the original controller so it is very possible the friction has existed since I got the machine.

I have a X-50 Woodworker with the same issue.

Mine is caused by the X oil port screw on the back of the gantry. The drag chain rail rubs against the screw, it pushes the chain rail back out of the way until it gets near the end where the rail mount is attached and it cannot push it back anymore.

Can’t simply flip the rail because the motor must mount on the right side.

Just got another message from OF Support (who are being very responsive and helpful) is saying remove the Ball Nut and spin it around 180 degrees.

This should work If I don’t screw it up, no pun intended.

2 Likes

Sorry for the delayed reply @mhackney. Yes I did get a resolution to my issues, long story short it was a maintenance issue. I regularly clean and oil my machine but apparently it collected a little more dirt/dust than I had expected recently.

1 Like

Thanks @Whistler I ended up contacting support and worked with a support guy via email over 2 days to run the tests they asked and diagnose the issue. It was a very good experience but it did require following their requests to the letter - something I always advocate when folks ask me to help them!

In my case it turned out that my X rails were slightly twisted. This could have happened during handling when I disassembled my Journeyman to do this ELITE upgrade. The fix is simple and documented on Onefinity’s YouTube channel (for Y rail twists). The machine runs like a top now and I’m getting comfortable with MASSO. I’ve used a lot of controllers and control software over the years, they all have their pros and cons but overall MASSO seems like a good option. Mach 3/4 was amazing but was really designed to be extended by users and had amazing tools (Brains, etc) to do all sorts of crazy things. But with this comes complexity.

2 Likes