X, Y return to 0 instead of machine home

Is there a setting somewhere in the interface to have it default to returning to X, Y zero or a box I can check somewhere instead of machine home when done with a cut. This is getting quite annoying when done with a job and the fact that I have to watch where I place my clamps as to not get in the way of the Z.

Thanks in advance.

This behavior is usually defined in the post processor.

I looked at the last line and it says X0 Y0 and still returns home, I press the bullseye to go to the ‘origin’ and then it returns to 0,0. How can I edit that line to return to origin and not 0,0?

By “home”, are you referring to the lower left of the OF that is set when you home the machine on boot up, or are you referring to the xy datum set up for the project you are running? If the latter, all that is set up in your software. I run Vectric Vcarve Pro, and in the Material Setup section on the toolpath side, you can define all that. I usually set mine to be in the spot I wish to Z probe after a tool change. Hope this helps.

2 Likes

If using Fusion360, replacing “G53 G0 X0 Y0” at the end of the NC file with “G54 G0 X0 Y0” will resolve.

Hey Timi,

Hey Timi,

that sounds logical. If you have a G53 (use machine coordinates despite offset coordinates are in effect) command there, replacing this by G54 (or by something else or even deleting it) would solve the problem that the machine goes to machine home at the end of the job. However,

  1. the original poster did not tell us which CAM software they use. In case it’s a Vectric product, there is no occurence of G53 in the post processor and none in the example g-code file that a user in another thread recently uploaded here. There were no G54 coordinates in use, all movements were given in machine coordinates. So the post processor simply doesn’t know where the project zero positions are.

  2. I don’t think the user decision where to return at the end of a program is or should made in the post processor, but a step earlier: In the options of the CAM program, by a user selectable dialog. I think (as @Bern already suggested by the way) it’s worth looking if there isn’t simply an option for a user choice on where to return at the end of the job.

    However if it’s the case that this return to machine home is hard-coded in the post processor, the problem is to solve by simply deleting the line before the last line which says “"G0[XH][YH]"” in the post processor:

    begin FOOTER
    
     "M5"
     "G0[ZH]"
     "G0[XH][YH]"
     "M2"
    

    Then the machine will simply lift Z and leave X and Y wherever they are.

Welcome to the forum!

I was just about to post this same exact question. I am using Fusion360, however, I do not want to manually edit the NC file every time. Any idea on how to update the Post Processor code so that it just lifts to Z home and ignores X,Y?

I’m assuming this would be with 1F. It would be really nice to have a box checked to raise Z and return X/Y to origin. My problem would be solved.

Hey Jesse,

if the CAD/CAM Software includes such a home command at the end of the g-code program, the CNC Controller can hardly do something about it. It’s the duty of the CNC Controller to run the program.

If I would encounter such unwanted behaviour, I would browse the help pages of the CAD/CAM software or ask in their forum and try to find out how to deactivate this behaviour at the user level. As said above, I think it should be set on the level of the CAD/CAM software. And if it isn’t, I would look at the post processor and modify it.

1 Like

Fantastic! This resolved my issue! I have no problem modifying the code for this! Takes 10 seconds. Thank you!!

Hey Aiph5u,

It’s in the post processor, I would need to modify this. I’m sure it’s a single line of code or something of that sort. Have never had the need to do that before…

I simply opened the post in a text editor and replaced the header with proper code for my intentions… Have actually mod’d posts this way for other companies that had no pst for their new machines… Not difficult at all. Keep a copy of the original just in case.