XYZ Probe Issue

I’m having a problem probing my Machinist. Homing goes great and the soft limits are set to X 0/411 and Y 0/410 with the Z set to -133/0. firmware v1.0.7
I move the machine over to just above the circle on the probe (X124, Y188, Z-119) and hit the Probe XYZ button and it immediately errors out with:

Level: error
Source: Planner
Message: Z axis position -144mm is less than minimum soft limit -133mm…

Why does the machine think it’s at -144mm when the UI is showing me -119mm.
I’ve rebooted multiple times, dbl/trpl checked the settings… but still it fails… i’m at a complete loss.

Hi Daniel - welcome to the forums. Couple questions to narrow in on your specific situation.

Is the bit close to the touch plate? Are you probing near the limits of the machine? Have you checked out this thread to see if it helps:

Let me know and we can go from there.


Yes, the bit is within a few mm of the touch probe right over the circle. Nope… probing near the middle of the machine as my initial post mentioned… (x124, y188, z-119).

Yes, I found that link from another post and read carefully but it didn’t help.
Also this is not my first hobby machine, but is first time using this particular CAM software. I use CNCjs or Carbide Motion on my other machines.

Thanks Daniel - I poked around the forums and didn’t see another post with your situation, so I am at loss right now. Did you confirm the probe is working by touching it to the bit? Perhaps the controller needs to see connectivity first? I read something like that for the new SW version (1.0.7).


yup… i hit the probe xyz button and first step is validating it by touching the probe to the bit. I do that then the error shows immediately.
It’s like the controller itself is out of sync with the software somehow. If i’m at -119, why does it error complaining that it’s at z -145… this part doesn’t make any sense.
Unless the Z motor settings are wrong.
Do you know of a way to run $$ on the controller itself?

You can manually put gcode in with the MDI interface. No manual ‘settings’ like grbl though (that I’ve seen).

Have you tried zeroing at the current location and then probing? That should give you full travel from the current location.

Just tried zeroing and then probing… no go :frowning:

Man, I was hoping that would work. I’d definitely contact support - there might be an issue with controller (though it seems like a SW issue to me).


1 Like

Rgr, that, thanks for trying, really appreciate your time.

Ok, discovered my issue and totally made assumptions on the capacity of the machine when setting up my temporary wasteboard.
The -145mm it was complaining about was the calculated value of where it would move the Z to when probing the X and Y.
It boils down to my spoil board was far too low.
I mounted the machine on the surface, and immediately added t-tracks with an 3/4" mdf. Seems my machine can’t reach that far down with the Amana 46200 bit i was using.
Raised my stock up and it probed properly.

1 Like

Glad you got it cleared up Daniel!