Y Axis clunking, losing position

Hello all, I did some digging into this issue of mine and tried a few solutions with no luck so far. The Y axis makes a loud clunking noise every now and then, and recently one or two of the stepper motors would squeal or grind in the middle of file. This causes the position to be lost, but not all the time. Here’s what I’ve tried so far:

  • Checked resistance between Y axis cable connector and rail/feet (both sides) = nothing.
  • Checked set screws at stepper motors = tight.
  • Recently cleaned all ball nuts, wipers and oiled machine. (this has been going on even prior to this).
  • Wiggled connectors while machine is running = doesn’t trip anything.

Anything else you guys could recommend?
I’m not sure how to check for EMI as that could possibly cause this?

Any help appreciated. I run products daily so it’s a high priority I get this solved. Thank you!

Listen at 11sec. for the noise.

That sounds like a step loss… Have you adjusted your accel and jerk settings… May need to lower them on that axis

1 Like

Yes it is skipping, I contacted support and ran through all their tests. The large nut on the end of the Y ball screws were a bit loose but even after tightening those it still has the same issue. I do not have the jerk settings set that much higher than factory. A few observations I made today after taking apart today.

  • Left Y Axis is definitely the one making the noise
  • Left ball nut has considerable play
  • Left ball screw has considerable runout

I’m going to send those findings to support and see what they say.

1 Like

If I remember correctly after cleaning and putting things back together I had to tighten and loosen things a bit to get things happy again… I had things to loose in some places, to tight in others.

Unfortunately this has been going on for a while and it only recently starting skipping steps. I suspect the ball nut could be worn out. It seems to be the only thing that caught my eye.

It’s very odd, because you’re using a laser, which exerts zero cutting pressure on the machine (as opposed to taking a large, deep cut with the router). Additionally, your machine appears to be perfectly clean, so it’s doubtful there’s an issue with swarf binding the screw. For these reasons, I tend to think @Hermsen.BJ is on the right track regarding accel & jerk settings.

I will mention that I had something similar happen on my machine, but it turned out to be one of the cable connectors which had a loose connection. Merely bumping the cable would cause it to make the same noise on my X axis. You would check this by jogging the machine, and wiggling the cables at the same time.

Hi Bill, yea its very odd. When I’m cutting out parts it never skips, only with the laser recently. I ran a few programs and wiggled all the connections and couldn’t notice anything. It happens so randomly. I think lowering jerk and accel will help, I just want to make sure I solve the underlying issue.

Updated to v1.1.2 and so far no more noises.

1 Like

Well that’s some excellent news!

1 Like