Y Motors not moving - Solved!

Reposting from FB Group:
Y motors not moving ?? Solved!!
Finally assembled and all was working great! I had relocated Y motors to the front and removed the cables from the Y tubes so I could just go down through the table under the motors. First assembly I just had the cables across the table. Installed my first layer of waste board, drilled holes below the motors and reconnected everything. The wire I pulled from the motor had an “extension” that I removed because I had way to much length. Upgraded the firmware and the Y motors just shook, no movement! At first I thought that my perfect first layer waste board had pushed the feet out of square. Resquared machine, still no movement. I then notched the four corners so that the feet did not touch. Still crap for movement. Disassembled everything and assembled again, crap. Seven Onefinity Support emails with videos and pics later, problem solved! In the Y rail is a connection. That connections is a male and female molex just like all the others. The stepper motor is hardwired and terminates to a connector midpoint in the rail. That connector connects to an unwrapped 4 wire cable which terminates into the molex connector at the other end of the rail. When you swap the motors to the front AND decide to not run the wires through the rail to the back you end up with a lot of extra length. I just removed that 3 foot length and went from motor to the cable that connects to the controller. That’s when the problems started. The wire that is normally in the Y rail tube is a crossover cable. When I moved the motors to the front I tossed the 3 foot piece thinking I did not need the “extensions” that were in the tube. WRONG. The black and red wires crossover in that cable which send the correct signals to the stepper motor. After many back and forth(pics and video) with support and taking the whole frame apart multiple times he had me hook the left Y motors to the X controller, same result, crap. When I went to connect the right Y motor my cable was to short to hook the X control wire. I grabbed the “extension” and that’s when I noticed the difference in the pinning! Simple crossover cable. From 1F support - “We have to cross them because the stepper motors come out different than the pins into the controller. We do this in the wires in the tube.” Well sneaky little devils! Hope this makes sense. Including some pics of the cable. The the last video to Onefinity before I figured it out is available on the FB page.

3 Likes

Yep, I ran into this when hooking up my custom controller, only the Y axis was the only one that worked after removing the extension harnesses. After messing around a bunch, I realized what was going on when I hooked up the 1F controller and the Y axis didn’t work, but X & Z did. For some reason the Buildbotics controller requires this strange cross of the A & B stepper coil windings.

FB link: Facebook Groups

1 Like

Yes, I completely agree that Buildbotics controller requires this strange cross of the A & B stepper coil windings and if not done in this way then the Y motor do not move. For more information go to servo drives repair.