Z axis offset and no cutting into surface

Having an issue where weather i use the probe or a piece of paper to set the Z offset, the bit won’t cut into the surface. Trying to make a simple grid on my spoil board. The gcode worked earlier in the day as well. Offset stays the same when the cut is started but when i stop the cut (since it isnt cutting anything) i am able to slide a piece of paper under the bit (even though the screen says it is -0.03 inches lower than the offset which i have set both by probe and paper. I can do this over and over again and the offset will go from -4.37 to -4.52 all without ever making a scratch on the surface. I took a video (to large to upload) of a single sequence of me adjusting to paper, running the gcode and it not making a scratch on the surface, took a picture of the screen after i stopped the gcode from running (attached).

This all makes no sense to me. At one point the bit all of a sudden gouged way down into my waste board after several times of adjusting the offset by paper and probe. Its like it doesnt see the offset change until some random time and then it puts it all together at once and it goes a half inch deep.

A few clarifications: I have the router/vac on one 20A circuit, the controller and screen on seperate 20A circuit and made sure that the 120v wires are not close to the low voltage wires because of potential EMI (they were together since i have the shielded low voltage cables grounded to the controller box but i seperated them to make sure that wasn’t the issue).

Always tricky to fully understand the situation but as a starter question, have surfaced your spoilboard (that is, flatten it with a surfacing bit)

1 Like

Hey Jordan,

if you enter G-code commands into the command entry field of the MDI Tab (in the Tabbed Section), can you check if your Z axis moves to the correct positions?

e.g. with

G1 Z0.3

This should move Z axis 0.3 units upwards at 1 unit/minute feedrate.

G1 Z-0.3

This should move the same amount downwards.

(G91, G90: Using incremental mode to move a bit and then reverting to absolute distance mode)
(G1: linear move with feedrate F)

Andy, yes, it flattened well and i also drilled holes in it for threaded inserts with seemingly no issue. I checked the flatemed spoilboard with paper and bit in 4 different places and all came out exactly to the same offset so i know the spoilboard is flat.

Aiph5u, yes, both commands work and move the z axis .3 inches in either direction at the feedrate of F1.

1 Like

Hey Jordan,

if the machine works correctly (the Z movement) then it must be your file or your probing workflow.

Aiph5u, do you have a best practice for probing workflow? Before loading gcode/after loading gcode, etc?

Hey Jordan,

me personally would always have the probing in the g-code file, and make sure that the ‘tool-change’ routine suits my needs, as explained here.

But generally if you don’t have probing in the g-code file, I would do probing before running the g-code file. As always, you must ensure that your real zero position that you are probing matches the workpiece zero position (aka part origin) in your 3D model.

Onefinity has made these videos for probing:

I assume that since you want to mill lower than your wasteboard surface, in your 3D model, you forcibly must have set the workpiece zero (aka part origin) on top of the workpiece? Assuming that the wasteboard is modeled as the workpiece.

Aiph5u, I have gone through those videos and set everything up accordingly. Used my calipers to fine tune the settings for the probe block. I have set zero for Z using the paper trick and the same thing happened so its not a probe issue.

I have the spoilboard modeled in Carvco as my stock and I have z set to top of material. I have asked this question on the carveco facebook group with my settings screenshot and no one saw any issues. Im really starting to think its a controller issue. I tried probing before gcode was loaded and after with the same results. The issue is VERY repeatable (even after cycling power to everything). I feel helpless. I’ll reset to factory defaults and see what happens and worse case reimage the SD card with the rasberry pi operating system for onefinity and see if that takes care of it.

Any other suggestions?

Looking at the picture of the screen it seems as though this is a huge file. It shows time remaining of over three hours. Is your grid set up to take that long to complete? I wonder if there is issue with the plung rate and the number of passes it will take to complete the grid. I am not sure, but something to look into, other wise it should not take over 3 hours of carve time to complete the grid.

Thats the local time. 3:06 in the afternoon. Below it is the time to complete. 8 minutes. I actually think it is a carveco issue with the amana 60 degree bit. I created the toolpths with a generic 60 degree v bit in carveco and the grid worked great.