Z Axis Stuck and Won’t Home

Hey-O new guy here. Just got my machine set up, and I’ve browsed through the forum here but I can’t seem to locate a post with my same issue.

My Z axis is free and I can spin it easily when the machine is off, everything moves fine. Then, when I turn the machine on and try to home, the Z axis doesn’t do anything. I try to move it using the control screen, and it doesn’t go anywhere either.

Any help is very appreciated as I’m excited to get cutting chips!

Is everything plugged in correctly? Or plugged in all the way?

Yeah, I went and double checked that everything is plugged in. I even unplugged the connectors and made sure that they clipped shut.

Have you tried restarting the control to see if anything changes?

Yep, tried that too. Turned on and off a few times.

Also, does it try to move? Can you hear the stepper try to move the z or is it quiet?

It makes noise like it wants to, but doesn’t go anywhere.

1 Like

Give this a shot then. See if it makes a difference

The problem is, I cant even move the axis. The Z is completely frozen when the machine is on. I can spin the screw by hand when its off, but when its on it freaks out and locks up.

It’s normal for stepper motors to be locked when they’re powered on. They should not be free when active

1 Like

That is actually a good sign that everything is working in my opinion

The controller wont move it either though.

Did you look at the video I sent? Later in the video it gets into how the homing works. It works on amp load of the motors. If you watch they show you how to adjust the amp load to allow the motor to turn. You will notice this under jogging or homing when it occurs. It will just stop or sounds like it thumps and won’t move.

I’ll give it a shot and see what happens. What’s the worst I could do…

The controller has to be lit on the upper two lights over the middle button in order for it to work. Hold the middle button 2 or 3 times and you’ll see the lights change. If it is lit below the center button the z axis function will not work. The lights have to be directly above the center button

My controller stumped me the first time I fired my machine up too. There are other posts about that in here and I believe some YouTube videos as well.

Ok, by controller I meant the screen. What term are people calling the machine interface screen? And no luck adjusting stall homing. I wish I could send a video along with my post.

Contact Onefinity Support

Support@Onefinitycnc.com

They usually respond quickly

If you are not using the stock z axis cable check that it is wired correctly. The stock cable has a crossed wire.