Z axis is crazy (solved, replaced extension wire)

While engraving a piece using VCarve pro everything was fine until the Z Motor made a chattering noise and the bit plunged through the piece. Restarted and ran for a while and same thing. Got out some scrap and tried a different file. machine ran for awhile and Z went nuts again. Oh and this seemed to start shortly after I crashed a bit into a clamp and broke it off. I would ask if it has lost it’s zero but there are times when it seams to work ok. Intermittently, Its as if the Z does not know where it is starting from. seems to be getting worse.

Checked the forum and did some tests with the joystick . Sometimes the Z goes in the correct direction, sometimes it goes in the opposite direction of what is supposed to. This is limited to the Z only X&Y seem to function properly.
Trouble shooting suggested motor or cable. I ordered Both and installed. Cleaned Z screw and fired up the machine. Its almost as its the Z does not know where it is at. When I try to home, it heads for the top like it should but stops and reverses about 1 - 1/2" before the top and heads for the bottom, then E stops because it can’t find the limit.

I have not replaced cable extension yet. Checked pins and sockets visually, and all look OK. Upgraded firmware to latest still does the same thing. Homing does not work b/c it will not home properly.

Sorry for the long post just trying to cover everything that I have done/seen.

Any Ideas?

1 Like

Hey Tim,

an issue where the Z goes into the wrong direction or plunges into wasteboard can be found repeatedly in the forum. Usually it’s a cable connector problem, possibly in combination with the lack of strain relief on this machine (see my comment here).

The manufacturer addresses this in this document:


I replaced the Z axis motor and Z axis motor control cable with new ones ordered from Onfinity, I did not replace the extension cable from the new motor cable to the controller -Yet.

I guess what I was trying to get to was the fact that now the Z Axis will not home as well as won’t mind the joystick controller.

Its like it does not know where it is at. Is there trick to installing a new motor where Z slider needs to be in a certain position before locking down the coupler between the motor and the screw, like all the way up or down? Could my coupler be slipping?

When they say in the video on replacing the y/x axis motors to tighten the screws on the flat spot of the motor shaft does this mean that the flat spot should be aligned with the cut in the coupler? I did not see a flat spot inside of the coupler. Sorry so many questions, and thanks for your help so far. Going to shop to re-check the connections. Thanks Aiph5u & Onefinity for your responses.

1 Like

Hey Tim,

I don’t know why you should have replaced a stepper motor, especially not before having checked and/or replaced all cables and connectors involved (except if the motor’s connector is failing and you don’t have the capability to replace and recrimp the connector yourself). If you look at this, and generally consider this, you know what you should look for. Stepper motors are by far not as common a cause of failure as these tin-plated connectors, which also lack strain relief (in fact the have a little strain relief on each contact in form of the insulation barrel, but these connectors are explicitly not made for use in moving parts (like in a CNC) and therefore necessite the use of strain relief.

The other point, coupler slipping, should also be a suspect when encountering Z positions issues. This is point 4) (ball screw coupler) in this FAQ document. If the Z axis’ ball screw coupler slips, this could be an error that could appear under load and not when milling air.

The flat surface on the motor shaft has to be aligned with the tip of the grub screw on the coupler.

While you’re at it, you could also check if the ball nut set screws are tight:

But first I would check and/or replace every cable and connector involved.



Thanks for all of your help. You are right the stepper motor would be the last to fail but I had no way to check pins and it was cheap. So Now I have a spare motor.

I went to the shop to do some more troubleshooting and sure enough I found that it IS the one cable that I did not replace.

I unplugged and plugged a couple times and the machine worked normally for a while, then started acting up again. Initially, I did not worry about this cable since it just hangs there and does not move. I guess the weight of the cable along with vibration and no strain relief other than what you describe in your post caused the failure.

I will go through and tighten the crimps and the barrel the connectors, also order a new cable for now, and start figuring out some way to keep this from happening again. I’m not too worried about parts since they are realtvely cheap, its the expensive piece of wood that gets trashed when this happens unexpectedly.

Thanks again for your help.