X50 Journeyman homing problem

Machine appeared to have a problem during a job that I have run several times which resulted in the end mill plunging through the job: I hit he emergency stop! I powered everything off and then started again but the controller won’t move the gantry and selecting the "home " command on the screen has no effect.

Up until now everything has performed as expected. Need some suggestions/help

Have you found a solution to your issue? Is it one axis that won’t move or all 3 if you attempt to jog them around?

Hi Derek

solved half of the problem because after looking more closely at the various cables I found that the wire controlling the X axis had been separated from its extension cable so replugging it solved the X and Y problem. The Z axis is still not working properly so I think this is a wiring problem as well but have not had time to really look at it in detail. The controller operates X and Y as normal but Z is all over the place. X and Y homes ok but Z tries to bury itself in the base board. I will unplug all of the Z cables and hopefully I have some spares around and connect it up outside of the standard wiring and see if it behaves itself.

thanks for your interest - I dont think there is much of a user base in Aus. Cheers Jeff

Hey Jeff,

how long have you been using the machine?

Welcome to the forum!


Thanks for the welcome.

I have been using the X50 since early Dec 2022. Fair learning curve particularly Vcarve Pro and getting to grips with Vectors. Made a few small projects and will hopefully be able to devote more time to it in the coming months. My current priority is to build a cover to cut down the noise…jeff