Homing problems

So this is the fourth time I turn the machine on and the x axis NEVER goes all the way to the left. Getting annoyed. I’ve searched the Homing stall videos and tried the steps. However this keeps happening. Any ideas

Another instance, Machine sat there for about 20 mins unused while I went inside. Now it won’t home Y all the way about 1/4 inch before reaching the end, I figured maybe I left something blocking it from reaching but nothing there… Am I doing something wrong? I’ll get a hold of Onefinity in the morning, problem is I am at work until 4p PST so I can’t troubleshoot live… Any ideas? Have to finish some projects but xcarve is packed up and I have had nothing but issues so far.

For me, it sometimes does that so I jog it over a little more towards the stop and try homing it again. This usually works for me.

It took a bit of tuning for me on 1.0.5 firmware but on 1.0.6 beta it was much better.

It doesn’t allow me to jog it over… Only way is to shut down the machine and move it manually.

It should allow if you unhome it as well.

The joystick will jog it. You don’t have to shut it down.

Joystick won’t do it either

Ok, I am assuming it’s me doing something wrong or missing something. Here’s a video of my problem. Any help is appreciated.

You need to adjust the stall homing. There is an issue with the settings. The video walks through it. There is both volts and amps that you step through. I initially did only bolts and that wasn’t enough. The beta firmware (1.0.6) also shifted it a bit.

1 Like

I tried that, but didn’t work. However I came out to the machine again to retry it, hit home and it finished going the rest of the way, confused. Thanks for your responses. Just gonna get a hold of Onefinity.

I have had mine do that exact same thing…happens randomly. Considerd upgrading to 1.0.6 but sounds like it still has some other bugs to iron out.

Is it out yet or just Beta? How do I go about upgrading if just Beta?

Support has the instructions

Just wanted to say thank you to Onefinity. Reached out to them on Feb 18 (last Thursday) at 9:15pm PST. To my surprise they responded within 3 minutes. They sent me a replacement screen and controller because I was having problems. Today Thursday Feb 25 I have my replacement parts. Up and running now flawlessly. Thank you guy’s. Support is second to none, I am really impressed by the machine, but waaaaaaaay more impressed with your customer support.

2 Likes

I’m having the same issues with my Woodworker X-35. At first it only slightly reduced the x-axis by about an inch, but I was still able to use the rest of the space. Now it’s gotten much worse and it limits the Y axis to about 5% of its range, so now I really need to fix it. Any suggestions beyond getting a whole new controller and screen like wsj-productions?

Did you try reaching out to support yet?

It turned out to be an easy fix by just increasing the stall current threshold of the affected motors. To do this, open the menu on the left, select motor 0 for the x axis, or motors 1 and 2 for the y axis, scroll down to the homing section at the bottom, and note the stall current threshold which is 1 amp by default. Increase it by a small increment of about 0.1 amps, which brings it up to 1.1 amps. Save the changes and try homing that axis again. If the problem persists, increase it a bit more and repeat until it works, then do the same process on the other axis that has issues. My x and y axes worked at 1.3 amps. My z axis never had the issue.
Relevant side note: a similar procedure can be done to fix an opposite issue of the motors trying too hard to go past the end. In that scenario you decrease the stall current gradually until the right equilibrium is found.

2 Likes

Just watched my video. Cringeworthy. Glad you are up and running.