1F unusable, Controller or VCarve issue?

My 1F has pretty much become unusable. I have posted before under a different topic, because I though I had a series of EMIs, which was possibly not the case. I have had 1 year of 1F use without any problems. After I installed the pwncnc spindle recently my problems started. I am not sure if the spindle installation is related. Today I went back to my Makita, and I have the same issue. Even when I dry run the toolpath as in the video.

Nearly all of my toolpath are affected by erratic movements, it happens in different projects too. The movements seem to happen at the same point of the carve. The X,Y,Z sometimes become unhomed or offset during the carve. In the video you can actually see a lot of the faulty cuts I had in all toolpath. I even recreated the model in vcarve without change.

What could cause this?

Has the controller been damaged by an EMI from the spindle?

Is this caused by vcarve?

Made with Clipchamp

I am not sure how to embed a video, so I added a link.
You can see the erratic behavior on a dry run.

The video shows you are loosing steps, most likely because of a billion nodes in the arc parts of the cut. Check node view in your cad.

1 Like

I imported an stl file in vcarve and then created the toolpath, I do not think there is a way to see the vectors. Also, this method has worked very successfully in the past. The only nodes I can edit are the outline of the stl.
I tried importing the arching of the model as a subd as well as a nurbs, made no difference. Also from my experience vcarve can handle meshes with 1 million polygons without any problem, but I think my file is much smaller than that. The errors also happen in the profile toolpath. The profile toolpath has about 100 nodes.

What I could do is recreate the toolpath again in vcarve in a lower modelling resolution, but somehow I would not expect a change.

reduce the nodes to 10 or less.

Hey Tom,

you have a lot of suggestions for probable causes in the other thread. Here, for me, the information that you are using the machine since one year (and that it’s not dependent on router or spindle) immediately triggers a strong association with the well-known “Curly Z cable is not made for permanent motion and shows signs of internal hidden cable breaks resulting in sudden unexpected Z moves or steplosses, that usually appear after one year of use” issue. Could also be the Molex stepper sockets on the left of X gantry which are subject to permanent motion too (and are not made for this too).

Also even with many nodes I believe it should not loose steps or erratically lower Z axis

1 Like

Plus one for the nodes theory. I had exactly the same problem and reducing nodes solved it. The tell for me in the video is how slowly the cut gets when it happens

2 Likes

The tell from the video is it does it in the exact same spot on the second pass as well. Nodes is most likely the case.

2 Likes

Hey Tom,

I’d like to see your video too, but when I click on any of the links I just get a page with still image. Even when I press “play”, no video is playing :frowning:

If you can export it as .mp4 in the application that you obviously used, you can upload the file here with the “Upload” icon in the top bar of message composer window. E.g. like this:

Or can’t you simply upload the video to your webspace? Usually every person that has internet at home (DSL) also has some webspace for free, e.g. here is mine. I can upload videos to it and it is accessible freely to the WWW

1 Like

I am convinced now it is a software problem as most of you mentioned, I’d did not know there was a ‘too many nodes’ problem. I guess that has to to with the limits of the buildbotics controller as well as VCarve?

The way I create my projects is to draw in Rhino, export the model as an STL, import in VCarve.

I do not work with vectors and do not draw vectors in VCarve, so the only way to have less nodes is probably the modeling resolution.

I will try to change the modeling resolution in VCarve from extremely high to high tonight and run the same model again.

Hey Tom,

I would be very pleased to read your report about the results!

Tom,

Look at V-Carves help files or Youtube videos for using “Bezier Curves”, That will chop the living daylights out of nodes on a curve.

1 Like

Hey Tom,

okay now I had success with watching your video above by using another web browser.

But in the other thread you posted these issues:

This seems to be a different issue than in the video above…

Aiph5u, Actually I think the problems started at a certain point in the carve, I guess there are too many nodes in this certain location for the controller to handle, maybe because of the shape of the arching. I now think what is pictured in the first picture could be a software/controller issue. I did run the toolpath in the pictures more than once and the controller went haywire at the same spot.

This includes unhoming X,Y or/ and Z and other issues.

The three channels in the picture above were due to an issue during the profile toolpath. At a certain location the controller was not able handle the amount of data, and it would then offset X and Y, and continue with the profile toolpath, but with the wrong X Y

One more reason to upgrade to a better controller.

I just finished carving the same model with a different resolution and no issues.

The only difference in the settings were the VCarve modeling resolution in the job setup, I changed it to to very high from maximum.

Many thanks everyone for helping, especially the 1F team that was the first to point me in the right direction

2 Likes

I use Vcarve and always thought the modeling resolution only affected the resolution on the screen for preview, not for the actual model, very interesting.
Thanks, Pat

1 Like

IMO, it’s completely counter-intuitive to expect the software to ADD more nodes to an imported design based on this setting. Adding more nodes to a vector curve (for example) curve doesn’t make it higher resolution.

It happens if there was a step in the process that includes a DXF file format. DXF is a lowest-common-denominator file format and was created before affordable computers could manage bezier curves. Instead it uses a calculus derived method of approximating curves using multiple small chords or segments - the higher the resolution, the smaller the line segments are to better represent the curve.

Bezier curves are now used because even cheap computers (like commodity PCs) have the processing power needed to calculate the curve mathematics.

But DXF’s attraction is that because Autodesk released the format to public use as an open file format. That got it supported by virtually all CAD programs which of course helped Autodesk dominate the industry :slight_smile: Virtually every design software supports DXF as an import or export file format. Of course that means it needs to be a simple format so that regardless of the capability or complexity of the software or the computer, it can be used.

Although it’s a 2D format, it’s even found in 3D design programs. Regardless, a complex file design capable software application will create nodes (end points of the small lines or chords that DXF uses to approximate curves) when saving in a DXF format. Then when that file is opened and saved in another more capable format like SVG, it will retain the nodes/chords even though the SVG format can easily support bezier curves.

Now you know more than you ever wanted to about node creation in otherwise smooth looking vector curves :laughing:

1 Like

Thanks for the run-down, I didn’t know that about DXF - I honestly can’t even remember the last time I saw a DXF file. I’ve been using Illustrator since the mid-90’s and assumed everything was using bezier or b-splines.

1 Like

Hey Tom,

given the fact that you use the machine professionally (what I also plan to do), I wish you that in any case that in the end it is possible to have a machine, and a mastery of the CAM software, where you do not have to feel that you cannot rely on it. Because that causes stress for sure!

1 Like