2 jtech question's

  1. i was really hoping for one of the latest firmware updates would fix but… m03 s10 command still being ignored. This is preventing me from doing things. I can go from laser to router no issues but if i need router then laser becomes a true pain. once you home cant get laser to test fire unless full power (with switch) or reboot cnc.
    2nd: Will i be able to fully control the laser with lightburn? or is this not being worked on anymore? have not seen any updates on this for a bit. I love the holding your shift key to show project outline in lightburn. I also own a laser master 2 so i know somewhat of lightburns capability’s.

Have you tried going from router to laser without homing? I seldom home my machine- just set xy coordinates. Maybe the m3 s10 would work for you.

Light burn should work fine as the controller uses GRBL. The last that I checked holding the shift key will outline the project.

In Vcarve, can I set a ending script in the gcode for it not to home after it completes? I can with 3d prints in S3D. I have more experience with 3d prints then cnc. I dont think even that will help me. once i go from my vbit setting to the next vbit gcode. and i cant do both at same time. 2 different depts. (1 @ .02 and 1 @ .05) i will have to home before laser gets attached

In VCarvePro it does not automatically home after a carve. Also it will always ask you if you want to home and give you the option to cancel homing before it homes.

1 Like

Well mine after it carves it moves back to home position. (using Vcarve pro 10.514 and the version before this as well.) it does not ask never has. only time i have ever seen this ASK is right at bootup
Maybe a setting is different from me to you?

I’ll just keep rebooting before i use the s10. It’s not a horrible work around its just getting annoying. Was really hoping to see it fixed in the last firmware update.

You could edit the post processor and take out the G0 [XH] [YH] in the footer section. That tells it to go back to home (work zero not home the machine) after the cut is done. I would save this as a different post processor so you still have the original. This is how I did when I edited mine for rotary use when adding a wrapper. Or you can just open your gcode and take out the G0 X0 Y0 at the end of it. And it won’t go back home.

Curious, how does one open up the g-code and edit it?

After you save your gcode, you can open it with a text editor, like notepad or wordpad. And then you can review it, edit it, and save it and then upload it to the Onefinity via USB or web interface. And run it like normal.

Thanks Roger, I opened up my pp in notepad and found the G0 [XH] [YH] commands in the footer and header sections but my machine never homes unless I ask it to. So why would St0mp get the homing and I don’t?

Those commands at the footer of the post processor return you to where you set your work zero not home the machine back to the very bottom left of the machine. If say you put a piece of wood in the center of your waste board and move your router to where you want to zero and hit Zero. This is where you will return with those commands. If you delete them you will just end at whatever your last position was at the end of the cut and the z axis will raise up. I don’t think he was meaning his machine returns to the absolute 0,0 like it does when you do the homing the controller asks when you boot it up. If he does mean that then something else is going on.

Is your issue with returning to the original Z starting position? I thought you were meaning returning to X and Y zero positions. But re-reading your earlier post I see maybe you are meaning the Z instead.

Thx that helped. vcarve should allow gcode starting and ending scripts. I have the options in Simplify3d. Useful for 3d prints. I could see it being useful for this as well. editing the gcode works I was able to use my router, then laser and my S10 command worked with out reboot (only did once so far) thank you sir…

1 Like

Yeah I concur. If I need something extra at the beginning or end I usually just add or delete it from the gcode unless it’s something I need a lot then I just edit the post processor and use that one when I need that change.

Hope this helps… I noticed if you want to go from carve to laser, you have to hit the E-Stop button ON THE SCREEN. Once you do that it will take the homing off and allow you to use the laser command. That’s been my experience. Just make sure to have the laser where you want Z-0 to be before hand.

Hello. the answer for your 1. question:
before the m3 s10 command, click on the screen the tree lines → go to TOOL → UNCHECK dynamic power → and now run your m3 s20 command (mine m3 s10 is too weak, so I need to do the m3 s20) - now set your 0x and 0y → and then go agaoin to TOOL and CHECK the dynamic power. It helped for me, I have just figured out today. Hope it helps

1 Like

That is so much nicer then waiting for a reboot. I just tested this Woo-Den works prefect. the actual command i use is M03 S15 10 was to weak for me as well. but turning off the dynamic power and back on seams to work as you stated. Thank you sir…

1 Like