After 1.09 update movement controls now in mm

After I updated the buttons I use to move the spindle around are now in mm. Is there a way to change the units and adjust the accuracy of the controls? I would like the units to be consistent since conversions are a source of error. Am I better off going all metric, am I just fighting the software, or is there a way to stay in inch space that makes sense if accuracy is important to me?

Yeah, I saw that too. I went into the menu and it displayed “imperial”, but the jog increments remained 0.5, x, y and 5 (can’t remember the middle two). But when I jogged up the Z axis, it looks like it travelled 5in (maxing out) and not 5cm. Maybe they changed the UI? It would technically make more sense as the 100 increment was not actually 100 inches.

1 Like

I’ve had this happen…I had changed it to imperial in the settings but after reboot still shows metric on the main page. I went back into the settings to check it and imperial was still selected in the drop down but for whatever reason metric was displayed on the main page. To fix this, on the main page select where it says metric and choose imperial. Now it will be in synch with the settings and it should stay like this