Default units metric vs imperial

When ever I start up my machine the units of measurement default to metric is there any way to make it default to imperial

This seems to be something that is broken in the firmware right now. You can tell it that imperial should be default but the next boot is back on metric.

I didn’t pay attention to it and I homed the machine in metric and when I ran my gcode. Which is in imperial. Things were a little off .

I agree, this needs to be addressed.

The display units should not affect the quality/accuracy of the cuts. Can you expand a little on what you mean by “things were a little off”?


1 Like

I was running gcode for a threaded waste board i was making. I had .75 inch pockets at .08 depth with a .125 endmill. As the end mill worked its way out from the center of the pocket the machine was chattering like it was bumping up against something .and when it finished the pocket it stopped with a part not cut like it didn’t finish the last round about just 3/4 of it.i thought maybe i had a bad I reprogrammed it and ran it again. But got the same results. Then I noticed that it was set to metric on the controller. I set it to imperial and rehomed the machine. Everything ran great after that .

Sounds like you may have run into my .75" bug?

1 Like

That’s what my circle looked like . But mine seemed to go away when I rehomed my machine in standard from mm. but probably still related to the same problem

1 Like

This has been addressed before and OF gave us a new pp to replace the previous one. I chose not to replace it but to run everything, especially circles, in metric. You run the same program in metric and the problem goes away. After getting used to metric I like it better. That chatter only happens in imperial. You can try the new pp to see it corrects it.

I’m having the same problem with creating my spoilboard making .75" dog holes. It only clunks and makes noises when I try to make the dog holes. I tried changing my Fusion 360 design to metric and putting Onefinity in metric but when I push the play button it switches back to imperial and I still get clunking. So frustrating. I’m glad to see I’m not the only one that can’t make .75" holes. Makes me want to sell my machine and take up knitting!

I’m not sure why it is reverting back to english. I’m thinking that maybe 360 metric setting didn’t take. Make sure it didn’t revert back there. When you set Onefinity to metric did the screen read out in metric? I wish you had Vetric. I think it works best with the Onefinty and woodworking in general. But you don’t, so you need to get the two working together in harmony.

Thanks to Becca Pierce Lonsbery on the Onefinity Facebook group I found that if I changed my my Tool Configuration on the machine browser from “Router” to “Disabled” the clunking noise went away and I got perfect circles. So I don’t understand how that made a difference but it sure did!


Glad to hear it. One thing I’ve learned is that there is always a reason for things not working right. Nailing it down takes persistence. So never give up. Sharing what you learn will often help others.