Metric Imperial switching

Is anyone noticing this. Kept having to switch back and forth on the controller. Is it just me?

i have noticed for at least 2 months. Even if you have it set to imperial for your settins. Every time you start the machine you have to hit metric then imperial on the interface screen if your going to jog on the onscreen jog pad. Is it a simple fix yes (waiting for onefinity), Is it annoying, Yes.

1 Like

I thought I was going crazy. Kept switching

It was supposed to be fixed in version 1.08 according to an earlier post here. Might be worth a report to Support so they know it’s still an issue (unless you haven’t updated to the latest version yet in which case that’s where I’d go next).

Yeah, they fixed that in the latest patch (For me) - Upgrade if you have not already.

Just upgraded a week ago. And now I’m getting this. Not a huge deal. Just annoying. Also noticed that at the fastest setting 10 or 5 depending on metric or Imperial. Sometimes it moves slowly when jogging using the arrows. Anyone else?

@exineport, Thanks for the tip. I am already on 1.0.8. Maybe I will try to reflash.

I’m on 1.08 also and recently reflashed. I’m still having a problem with it switching.

1 Like

even on 1.0.8, you’ll still need to do it one time upon reboot.


I have to change to imperial every reboot. Even after loading a gcode file set in inches, I still have to change the drop-down to imperial.

Yes and happening in the middle of use. Not just the the first boot.

@OnefinityCNC Why can’t this be coded into the boot up? It has got to be an easy fix.

For the record, I’ve had the same experience lately. Disconcerting, to say the least.