Fix jog buttons to show imperial instead of metric jog numbers at boot

I love my onefinity but it has bothered me that once I found out how to set the units to Imperial so that it boots to imperial units, but the numbers on the jog buttons were still in the metric units. You always had to toggle the units to metric then imperial to get the jog buttons correct. I emailed and asked them about that and they replied that its normal and yes you must toggle the units even though it boots in imperial units.

So I did som digging around in the source code and found that the lines for the jog button are hard coded buttons at boot instead of making them a variable. So if you are comfortable with ssh you can do this. After the fix the toggle still works if you ever need to revert to metric units.

  1. ssh into your controller

  2. cd /usr/local/lib/python3.5/dist-packages/bbctrl-1.0.8-py3.5.egg/bbctrl/http

  3. sudo cp index.html index.html.orig

the above line does the following: makes a copy of the original index.html and names it index.html.orig

  1. sudo nano index.html (key commands are shown at the bottom of the window to get around in nano editor)
  2. on keyboard hit ctrl underscore (on my keyboard _ is with the - button, I hit ctrl- NOT ctrl shift-)

if you have a seperate keypad on your keyboard mine doesn’t work in nano so use number keys on the normal keyboard

  1. type 3078 (This takes you to line 3078 in the file). see the screenshot below with the red circle. We need to change those 4 values.

  1. change 0.1 to 0.005
  2. 3 lines down change 1.0 to 0.05
  3. 3 lines down change 10 to 0.5
  4. 3 lines down change 100 to 5
  5. hit ctrl o and enter.
  6. hit ctrl x
  7. reboot the machine

if you messed up and need to recover the backup you made in step 1&2 you can do this by doing the following

  1. ssh into controller
  2. cd /usr/local/lib/python3.5/dist-packages/bbctrl-1.0.8-py3.5.egg/bbctrl/http
  3. sudo cp index.html.orig index.html (this overwrites the index.html with the backup we made of the original index.html.orig.
  4. reboot

I don’t need this fix but I can definitely acknowledge some nice code snooping and bump this thread for others!


What are the log in credentials? I tried bbmc and onefinity but that does not work for me.


I changed my ssh user and password. I thought the default user was bbmc and password was onefinity. Let me know if that doesn’t work for you. Once you know the password you can change user and password in the network under admin in the settings.

*edited for the correct default user name and password.

Got it that was it thanks! And this fix works awesome!

This worked perfectly! Nice job on figuring this out. I’m impressed!

All that stumble across this for the new updated firmware 1.0.9, in step 5 you need to do search for 3107. Thats the start point where you need to make the changes.

You could go out to github and do a pull request which likely will help it get brought in more efficiently.

There is a 1.0.10 branch in the works already.

1 Like