Can't attach brush to dust boot

Hey, I can finally contribute. I got so frustrated trying to install the brush spine that I nearly went and spent what I consider big money on yet a different dust boot. but i could not find one that allowed me to keep using my light ring and I love my light ring so after cogitating a while I thought hmm, since it seems really just too wide I either have to widen the channel that it goes in or narrow the brush spine. so, I layed the straightened brush on the bench and gently went over the spine on both sided with 120 grit sandpaper. It worked I was able to push the still firmly fitting brush with my thumbnail and viola. It worked and has stayed in as well. I hope this helps someone. By the way I am challenging someone with a 3d printer to make a dust boot with magnetically installed replacement brushes and can work with a light ring and fit the Makita router. Now that would be worth the money.

1 Like

I set mine up two days ago and im having the reverse problem. The brush is loose. Its all the way seated, but can rotate. With the vacuum on, it sucked the bristles and embedded chips towards the vacuum nozzle and blocked half the opening. I switched between brushes and one is better than the other (the shorter), but overall i’m not too thrilled with my $150 Infinite Dust Collection kit yet. The Pwn collector sounded like it cracked when i inserted the vacuum nozzle, which now seems permanently installed, and I’m afraid to try too hard to pull it out after the cracking going in. I havent actually used that one yet.

Just venting, I guess.

1 Like

My brush wont stay in the groove. There are no retaining features to keep the brush attached to the boot. Does it need to be glued?