Can't attach brush to dust boot

Just installing my NEW Onefinity Woodworker. Watched the nice video on assembling the Suck It dust boot. I can’t seem to be able to insert the brush (1") into the groove. Any tips?

As I recall the inner dust shield needed to be removed so as not to interfere with seating it in the groove. Then I’m pretty sure I started at one end first worked then around it, finally using a dull (rounded) flat blade screw driver to make sure it set in the groove completely.
Others may have more recent memories on this though.

3 Likes

Make sure you loosen the magnetic sides before you insert the brush. Then tighten them once brush is inserted.

I did loosen the mag sides, didn’t help so far.

I did not try removing the shield. Doing that next. Will report.

I was having a difficult time, and it was the magnet screws that were the issue. It is hard, but once I got the clearance I was able to do it with some high effort.

Removed shield. Removed mag brackets. Still no love. Gave unit to my son to try, bristles detached from brush spine. Beginning to think I have a defective brush. The brush seems way too stiff to seat properly.

I had a hard time forming mine to curve smoothly. I set it out in the sun for an hour when it was 100 degrees and it went in a lot easier.

I hadn’t thought of that, but a hair dryer would probably work too.

I installed mine in a couple of minutes using a pliers. Grip the bristles all the way to the black strip holding the bristles with the pliers You can use this to concentrate pressure on the bristles and you just have to work your way around the channel. Good luck.

There is a specific way to insert the brush, it would be backward thus causing it not to fit. I second what @pwpacp said, a flat blade screwdriver helped to seat the brush.

before you start to insert it bend it to see that the brushes turn inward not outward… best to work from one end to the other, it took me a few tries and the screw driver will help!

I did that yesterday. I had the same dificulty. I had a brand new unsharpened #2 pencil on the table and I used the unsharpened end to push the brush in. There’s an upper edge to the brush that is flat that you set your tool’s flat edge onto. In my case the pencil. It’s time consuming. I push in a 1/16" at a time and worked my way round slowly but it worked out.

1 Like

My brush bristles separated from the spine, so I asked Onefinity for a new brush. Received it yesterday and it took all of 30 seconds to install it. The originally supplied brush had a spine that was way too stiff. A quality control issue, I think.

1 Like

Anyone who got an order near #18547 may have a similar problem if they ordered the SuckIt.

I was order 17267, and had similar issues installing mine. One end of the brush slid in like nothing, but the other half wouldn’t go in. Finally got it to go, but it popped a crack in the dust boot.

I agree I think it a qc issue wherever they are souring the brushes.

Edit: come to think of it, I ordered my suck it a couple weeks after I received my of, so it would of been much closer to your number.

My number was 18547. The replacement brushes they sent me later were fine .Definitely a QC issue.