Controller not powering usb ports

Hello all,

Thanks in advance. Couldn’t find a relevant thread. My controller on the X-35 does not appear to be powering the usb ports, i.e. the light on the joystick “thumbdrive” does not light up nor does the light on an actual thumbdrive. They did in the past I believe. This translates to the joystick giving me the circle of death and not connecting to the receiver thumbdrive and not being able to load NC files from the usb slot. I’ve stuck the same usbs into my computer and everything lights up/works.

The usb from the controller to the screen does work (meaning the touch screen operates fine) but that seems to be because the screen is separately powered).

Has anyone experienced this? Solutions?

Many thanks.

Is this a new machine/controller to you? Has it worked previously? Perhaps if so you might want to open the case and check the connections.

I’m not sure about the power issue, but the thumb drive needs formatting as FAT32 (and maybe NTFS) or it won’t read it. I don’t think either of those are the defaults these days.

Remove the touch screen usb wire and see if it “turns back on” the usb ports.

1 Like

Happens to me all the time. Unplug and reinsert the USB connector and you should be fine.

Much appreciated, Onefinity. I tried it - the USBs and receiver USB works after when I unplug the screen USB but immediately lose power when the screen USB is plugged back in.

Any further advice?

Unfortunately the instant I put the screen USB back in, the others lose power.

Possibly a bad screen or a screen that’s not getting power externally from the wall and sucking all the power from the pi to try to turn on.

1 Like

Hey trituimajin,

I would check if the separate power supply of the Touch screen really works and especially is plugged into the right socket. Does the Touchscreen light up when it is NOT connected to the USB port of the Onefinity Controller?

The gamepad receiver and a USB flash stick should alone should not exceed the power limit of the Raspberry Pi.

…, or, as is the case, with an even larger power supply inside the Onefinity Controller.

  • You also could try a USB 2.0 hub. They usually come with a separate power supply, which I would always use (in a wall outlet).
1 Like

Thank you, Aiph5u and Onefinity. I think you solved it. I checked the screen USB wire and discovered the router bit had frayed it a little exposing some of the copper (if that’s what they use) - so I suspect somehow affecting the power. When I bend it back and forth the dongle on the joystick receiver turns on correspondingly. I’ll get new wires. Many thanks!


Hey triuimahin,

where do you lay your cables :slight_smile: ?

Ha. Normal spot with the onefinity brackets. Wires come out of the right and i didn’t push the screen away when the router went home after a job. Am I doing something wrong?

Hey trituimajin,

yes, I know Onefinity’s default placement of the screen. Of course, this is completely counterproductive, as the milling motor and dust shoe protrudes the machine towards front. I find that the Control display should be on the right, as is usual on professional machines (but you need longer cables then)

But you can rotate the screen so that the cables come out on the left and then rotate the screen content by 180°.

1 Like

Thanks, Aiph5u! I’m pretty computer illiterate so I’ll be getting a larger touchscreen to mount on the wall eventually. For now, I just have to run through the checklist to make sure to push it back after I start a carve. Appreciate your help.

Hey tritimajin,

:point_right:Latest firmware 1.2.1 now offers screen rotation by 180° out of the box.

But I agree, I also use a larger control display and a more serious mount.

1 Like

I see you have the same wall situation, may I suggest the wall mounted option:

No extra cables needed, and no accidental touch screen know down.