Elite (Masso) set up in Easel

Newbie here. I’m setting up my Elite machine in Easel and I’m not sure whether I choose GRBL based or non-GRBL for the motion control option? I searched but only found information regarding the buildbotics systems. What do I need to know here in order to set up an Elite machine?

Additionally, I’m assuming I will be exporting a file which I will put on a usb drive to run the program. Can you tell me which export file type/option I will choose when presented with them?

Lastly for now, I will be engraving some text onto some softwood using a 60 degree V-bit, does anybody know what a good depth of pass setting I should use? .7mm (standard setting in the software) seems a bit shallow. Am I wrong?

Btw, does anybody know if you can send a program via wifi or must it be put onto the usb?

Pretty sure you can’t control masso thru your computer, so you’ll need to export the gcode. That being said it’s a masso controller, so non-grbl, but it doesn’t matter because of the first part. As to which post processor to use, i can’t help you.

As to the vcarve. It will only go as deep as the vector width will allow based on the angle of the bit. I would agree .7mm isn’t very deep. For context, that’s about how deep i go as a starting point so i can paint it and sand it down.

Check out Masso Link (Wi-Fi Connectivity) for wifi connectivity options where you can view machine status, transfer gcode and see tool information (according to masso)

1 Like


The post processor (file type) for the g code is Masso ARCS in either mm or inches, but that is what it is called in Vectric so I’m not sure about Easel. I think the later vcersions of Vectric (my version of Aspire is 9.5) might have Onefinity Elite as the post processor now. I’m not sure on that? The file extension for the Masso is .nc , so for example your file could be vcarve1.nc

Transferring via Wi-Fi can be done via Masso Link. My workshop doesn’t have wi-fi, and is about 20 yards from the house, and I can still transfer files from my computer upstairs. It’s handy for making changes, especially when you have ran upstairs and forgot your USB stick for the 500th time like on my old CNC!

Here is how to connect to wi-fi -


This link also includes a video on how to use Masso Link. You can send files direct to the machine (with the USB plugged in as this is the storage device). You can also send them to folders that you can create. Where you drag the file to, you just type in the folder you want to create\or the file to go to and drag it on to there. I’m pretty sure this is explained in the video.

On my 60 degree v carves, and I make a lot of signs, I have a pass depth of 1mm at 150 IPM, at 18000 RPM on the spindle, in hardwoods, and that seems fine and quick enough and gives me nice results, but I’m sure you could go deeper if needed especially in softwood.

Saying that, I tend to slow the machine down to 80% feed rate which would make it around 120 IPM, so I have room for manoeuvre if it’s cutting too slow.

0.7mm is very conservative. I’d ignore the Easel stock settings as they are designed for the X Carve and are conservative for that. A pass depth of 1.5mm would be more than fine if needed on the Elite, again especially in softwood, depending on your set up and speeds.

1 Like

Thanks Chris & John,

I was able to connect my Masso via wifi so I can now send files without having to go into the house and go upstairs where my computer is over and over. I was able to figure out that I needed to be able to export .nc files (Thanks). I did push up the depth of cut and feed rate considerably and found I could have done more. I used 400 ipm on a small sign and even faster would have been fine, although I’m not getting as deep of a cut as I’m calling for, so I have some troubleshooting ahead. I’m using the xyz probe and have adjusted the specs so I may try to manually set my starting points and see if that helps.
Thanks again for the responses!!


Off the top of my head, is the surface flat and is your wasteboard surfaced. If you’re zeroing z on a high spot it won’t go as deep as it’s calling for… same with on a low spot going deeper than you want.

1 Like

Here’s the interesting thing. I have run the file, setting it a various depths (ie. as much as 1/2") and it cuts at the same depth every time. I’ve even manually set the zero points. While the cut is happening, I can see the z setting on the Masso display and it’s usually showing it’s cutting at a z of -.01 to -.03 range. I’ve also noticed that the screen shows the feed rate and below that it says: Tool: 4 1/4" EM which is not the tool I’m using (90deg V bit) or the tool I set up to be used in Easel. Am I supposed to be making a change on the Masso, and if so, how do I do that?

I see the same thing on my Masso if I use one of my tools that has the same number as one of the tools that 1F has listed in the tool table it reads as per the table not the Gcode.
I see no reason to have the tools listed in the tool table unless you have an ATC.

Having the tool setter it is needed, especially if saving it as a single file


Regardless of where your z zero is, if your file says -.03, it’ll go -.03 from your zero.
Machine coords are different than working coordinates

I’ve been having trouble with the touch probe. When I say go to work origin after probing x and y, it’s always slightly off. I’ve tried measuring with my electronic callipers but they are rubbish and I think are the problem, as the measurement of the touch probe with my callipers that I entered into Masso was off, so I’m getting a new decent pair, and setting the x and y manually for now.

Hey John,

you know you can’t use the 3-Axis Touch Plate with a v-bit?

1 Like

Not sure I understand

Yeah sure, I know that. I always probe with a 1/4" down cut bit for x and y. Then probe z with my starting bit. After that I have a tool setter. I made the mistake of measuring the probe block with my callipers and entering in those dimensions, however the callipers are cheap rubbish and are out I’m sure. I’m going to replace them as accuracy is important for some applications, others you can get away with being ever so slightly out. Thanks for the advice though.

1 Like

If you have a single file with 4 tool changes in it, and their programmed correctly in cad, and the cad matches the f4 screen, it makes it easier because there’s a pop up dialog that says put in tool number 15 (then whatever you named it). If it’s blank, you have to know what tool 15 is. You said only for ATC, but MTC (manual tool change) is a thing too.

If the same file has 4 different toolpaths requiring different tools in it, but the tool number is the same, it would go from one toolpath to the next regardless of if that was the intent.

I was just saying you would want to do it for more than just ATC, and your cad programming “needs” to match what is programmed on f4… if it doesn’t you could put a ¼" endmill in when you needed a ⅛" endmill. At least I’m not smart enough to remember what tool 15 is without a dialog saying install “amana 45002”

Yep I understand now what you mean, I do usually have 3 or 4 tools in one program or file, but I do rely on knowing which tool is next, I suppose I should populate the tool table in Masso to match what I have in Vectric, in my spare time which is all I have.
Thanks, Pat

1 Like

Plug in an external keyboard. I did 2 or 3 on the touch screen and was like “screw this” and then it was boom boom boom. Took about 10 min to put in like 30 tools, i was numbering them down as their listed in aspire, but if i add something new, i check the last next entry in masso and that’s what number it is.

1 Like

Thanks for the keyboard tip, I probably would have used the touch screen at least to start with

I started there… but it’s slow… I’m not lightning fast on a keyboard but at least 50wpm, so i know how to type. Touch screen like 5-10wpm

I just wanted to Share I did a test export from Easel to generic Gcode file (a simple box pocket as a test) and the file ran fine on the MASSO controller. I use Vectric Aspire for all my work currently but notice Easel is adding a cabinet option to their program so figured that could really be handy…

1 Like

Yes, I run a MacBook so I never used the software that came with the elite, I went straight to easel and it’s great how easy it is.