Error when sending toolpath from laptop

Hey folks. I’m hoping someone can give me a little help. A while back I made a copy of the onefinity post in vectric and made an edit to show the tool info at the beginning of a program. I did it so I can see the tool I used just before I send it to the machine, as a double check that I’m using the correct one. Anyway, it turns out that the onefinity doesn’t like the degree symbol when using a vbit so it errors out. I removed that call out from the post but still get this error message every time. If I just keep selecting the toolpath I want it eventually grabs it and I can move on. Sometimes it takes like 10 attempts. Sometimes only once. It’s like it’s stuck in memory. Any ideas on how to get rid of this?

It’s the special character and length. Try renaming it to something simpler without special characters.

I’ve since resorted back to the original post but everytime I try to send a program to the machine, it comes up with that error. That was a test program I ran months ago. When I try pulling in a program to run it gives me that error. I just keep trying to send the new program over and over until it finally does. Sometimes that error comes up once. Sometimes as many as 10 times before it actually reads in the toolpath I’m trying to. It seems as though that error program in stuck in memory somewhere but I can’t seem to clear it.