F setting does not change feed rate (solved, use G1)

Finally got my 1F all setup and was trying some settings to get a feel for the machine. After home and successful Z probe I set the Z up a bit G91 G0 Z10

I moved the X over a bit G0 X100 F100 expecting a nice slow 100mm/m movement but instead it only took about a second.

So I tried G0 X100 F10 with same result and G0 X100 F1 same same.

Tried G0 X100 F500 still looks. to be about a second.

Am I missing something? I certainly am not going to run any gcode until I can control the feed.

Longer movements will get faster. It has fairly modest acceleration setting out of the box.

100mm is long? If I set F100 I expect 100mm/m, at least this what I see on my other CNC machines.

Could someone enter G91 G0 X100 F100 and tell me how long it takes to move 100mm?

NM, now I see. On my other machine using GRBL. Using G1 on 1F instead of G0 is working as expected.


Hey Dave,

this is by intention. G0 (Rapid Move) does not honor feed rate, G1 (Linear Move) and other movement commands do.

(The Onefinity Controller is a hardware and a software fork of the Buildbotics Controller, and the g-code used by the Buildbotics controller was patterned after the LinuxCNC g-code)

G-code#List of G-codes commonly found on FANUC and similarly designed controls for milling and turning