Z-20 upgrade issues/error

I finally got around to installing the Z-20 slider upgrade on my Journeyman and am encountering some errors that I cannot solve.

The physical install went fine and it worked before I changing the settings as per the installation manual. I also upgraded to the latest firmware 1.3 prior to this and then changed the settings. I cannot figure out what is going on and I even tried to change the settings back but I am receving the following error:

Non-rapid move with zero feed rate
While executing GCode block:G91 G1 Z[#<_z zero_backoff>] F[#< _z_search_velocity>]
At: :2
Caused by: -rapid move with zero feed rate

Anyone run into the same issue? Any suggestions so I can get this back up and running?

Reset the configuration and then restart

Thank you, I have tried that a number of times. Can you be more specific so I can ensure that I am not missing anything. What steps should I take? Anything else that I can check?

Hey Makermatt,

this is an error in your g-code. You cannot execute G1 (Linear Move) with F (Set Feed Rate) unset. Use F first to set it to a non-zero value.

2 Likes