Z20 axis Issues

So I recently upgraded to the Z20 and an 80mm Huanyang spindle. Since doing so, I have not been able to complete a job without the Z axis messing up. During cutting the Z axis will try to retract and fail. This will cause the next z plunge to be deeper than it should be. Alot deeper. Is anyone else having this issue or can anyone give me a tip on how to stop it from happening?

X50 Journeyman
V1.2.1 Firmware
Z20 Configuration selected

Hey Robert,

have you adjusted stall homing to reflect the new weight after switching to a spindle?


I have adjusted the stall settings to reflect the heavier spindle. Machine homes out with no issues. But once again while finishing a 14 hour carve, the machine messed up in the Z axis. Everything worked fine me before upgrading the to the Z20 and spindle. I am at a loss and very disappointed

So I have discovered that the standard max velocity for the Z20 slide is 7m/min as set by the configuration screen. However, 7m/min causes my Z axis motor to stall. At 6m/ min I cannot get it to stall. If I set it to a Buildbotics recommended 80% factor, I am at 4.8m/min. This is 1.8m/min over the standard Z16 slider. Not impressed at all at $375 for the upgrade. And just ruined a $60 piece of wood with about 14 hours of time into it.

Hey Robert,

did you try that:

You need to load the correct configuration:

This applies to firmware 1.2.1 and later.

Should you be on firmware 1.0.9 or earlier, after installing Z-20 assembly, you need to set these values of Motor 3 on its MOTOR page manually instead:

  • β€œtravel-per-rev” to β€œ10”
  • β€œmin-soft-limit” to β€œ-160”, and
  • β€œmax-velocity” to β€œ7”

This is what the β€œPick your Z Slider Type” choice sets (as shown in the image) above when choosing β€œZ-20 Heavy Duty”. The Z-20 assembly will work correctly if you set it manually this way.

The standard configurations apply to the weight of the Makita Router.

1 Like

I have followed all the proper installation steps. I am on version 1.2.1. I have loaded the configuration file for the Z20 slider upgrade. I have read all this and done all this. But when I jog my Z axis up and down manually, it stalls out and then loses position. I can only assume that when doing a 3d relief carve and having to transition between Z+ and Z- movements pretty rapidly at times, that it also stalls. I have now decreased my max velocity on the Z axis to 4.8 and am running the toolpath even though my project is already junk. I do many 3d carves and thought the spindle and Z20 would be a good improvement but it has proven to be nothing but a problem. I have lost all faith in this machine.

I do not feel comfortable increasing the drive current above the 2.8 amps as the motor is only rated for 2.8 amps according to the sticker on the top of the stepper motor. If this repeat carve fails, I will be returning the Z20 slider as well as my spindle. Possibly the entire machine. I am not happy at all.

Hey Robert,

what did support@onefinitycnc.com say to your issue?

The carve is still running and has made it past where it messed up last time. Looks like the velocity change may be the answer. I am sure this is due to the added weight of the spindle. But if the Z20 is sold with an 80mm spindle option, why would I have to slow it down in order to be able to use it.

Oh, and did I mention that it was originally a 14 hour carve and is now well over 21 hours. Doesn’t sound like an upgrade to me

Okay, I have been doing some research and thought possibly EMI could be causing my issue. I have noticed my screen flickering from time to time. I have rerouted some cables and changed the way things were plugged in. I have changed all my settings back to factory settings and am going to try rerunning my toolpath with no material. With no dust collection running, I will be able to easily hear if it loses position. I could hear it while the dust collection was running. Will respond with my findings.

It was indeed related to EMI. Machine is running much much better now.


After all that, would you kindly detail what you did to fix this problem entirely? Many thanks.

I found what worked was to only have the controller and the screen plugged in to one power strip and all my other things plugged into another powerstrip on another outlet. Machine is running way different than i was used to seeing. Much much better. I believe ibwas robbing it of the required amps. Simple but frustrating. I should have known better.