Z-20 (Heavy Duty Z-Slider)

I recently installed the new Z-20 (Heavy Duty Z-Slider) on my machine and fit it with the Huanyang Inverter and 2.2 kw spindle everything is working great except for the Z axis, When I hit start it plunges down all the way it’s like the motor is losing power. Do I need to change something in the motor settings to correct this problem ?

Hey Dan,

yes, you need to load the correct configuration:

This applies to firmware 1.2.1 and later.

Should you be on firmware 1.0.9 or earlier, after installing Z-20 assembly, you need to set these values of Motor 3 on its MOTOR page manually instead:

  • travel-per-rev” to “10
  • min-soft-limit” to “-160”, and
  • max-velocity” to “7

This is what the “Pick your Z Slider Type” choice sets (as shown in the image) above when choosing “Z-20 Heavy Duty”. The Z-20 assembly will work correctly if you set it manually this way.

Note that additionally when using a heavier milling motor, you can adjust (increase) the ‘drive-current’ and ‘idle-current’ settings the “Motor → Power" section of motor 3 on the MOTORs page.

Should also stall homing on Z axis not work correctly, you may also adjust stall homing settings (see here for details).

Welcome to the forum!

1 Like

Thanks very helpfull. You wouldn’t happen to know the default password so I can ,upgrade the firmware

Hey Dan,

depending on firmware version it is either buildbotics, onefinity or simply nothing (press return)

Here is something I cant seem to figure out, when I zero the machine and start a new program the X position is about 12 inches off it reads 20" all the way to the right when it should read 32.125 like the Y
any ideas on what is going on with my machine could this have anything to to with some changes I made after installing a new Z-20 heavy duty Z slider

Hey Dan,

Is the ‘travel-per-rev’ setting on motor 0 set to 16? This should be the case on all X-50 machines, and set to 10 on all X-35 machines (of the Original Series).

If you loaded the correct configuration on ADMIN → Configuration → Reset → (choose correct machine) it should have the correct setting.

1 Like

Homing has become an ongoing issue with my Z-20 equipped X50. When I start/home the machine the Z home often slides down anywhere from 2-4" and I have to go through the “adjust stall-volts” routine; sometimes 3 or 4 times to get it work right. This has become about 50% of the time now and it’s super annoying.

Anybody else suffering from the issue? Any better solutions? Thanks!

I have just installed a Z-20 on my X-50 woodworker with a Makita router.
When homing now, I continually have to redo the stall current/voltages for the Z axis. Everytime I home the Z axis, it needs adjustment. Very frustrating

1 Like

I am having the same issue at every power-up. I think mine may be related to temperature. My machine sits overnight in a relatively cool space. If I allow things to heat up a bit it eventually works out, but I can say that I never had this issue with the Z16 slider in the same environment over the last two seasons… What really p’s me off is when it drives negative when homing and I have to hit the estop or it will drive right into the bed, so I now remove any bits at end of day. I’m running version 1.3.0 with the BB controller. Another thing I have noticed is when the z motor is static, I can move it down by hand very easily, but moving it up takes considerably greater force. I realize gravity plays a part, but there isn’t much weight to fight there. None of the movement seems binding whatsoever.

The Z20 not homing has been intermittent, but now I cannot home it at all. I have tried every setting from 1 amp down to 0.5 amp (0.4 amp and the axis just stops) and 2 volts down to 1.1 volts with no success
Went inside to have a cup of tea out of frustration, then returned. Powered up the OF and reset (for the multiple time) the config to X50 Woodworker and Z20 z axis and voila, it is now working with stall volts at 2.0v and stall current at 1amp. It still buzzes a bit (for less than a second) on stall home then moves on to homing the x axis.
The symptoms are almost like it keeps losing the z20 config, but just guessing

Todays saga. Z20 wouldn’t home at 1 amp/2 volts.
Rest config, no change (no surprise)
Settings now at 0.5 amp and 2 volt and all is ok for now.

Updated to 1.3.1
Reset config to x50 pro and z20
Won’t home with stall set to 2 volts and 0.5 amps
Set stall to 1.2 volts and 0.5 amps
Currently seems ok…………

Hey Avbates,

there is a difference between X-35 and X-50 X axis setting. This has nothing to do with the Z axis Z-16 vs. Z-20 z assembly settings that are:

Z-16 Original/PRO default settings for motor 3:
travel-per-rev = 4,
min-soft-limit = -133,
max-velocity = 3,

Z-20 “Heavy Duty” default settings for motor 3:
travel-per-rev = 10
min-soft-limit -160,
max-velocity = 7

The ‘travel-per-rev’ setting on motor 3 (Z motor) reflects the steeper ball screw pitch on Z-20 Z assembly which leads to the spindle drop issue. The ‘min-soft-limit’ shows the increased Z travel of 160 mm on Z-20, instead of 133 mm on Z-16.

You can set these settings manually if you want to stick with stable firmware version 1.0.9 that does not yet offer a default configuration selection for Z-20 Z assembly that was introduced with firmware 1.2.x, it will work the same way.

Onefinity once responded to this question, it was about the max-soft-limits of the X and Y motor settings of the workarea (motors 0–2), saying that it’s usually a few millimeters more, but to allow for variations in assembly, it’s better to be on the safe side.

1 Like

Thank Aiph5u
Updated to 1.3.1
Reset config to x50 pro and z20
Won’t home with stall set to 2 volts and 0.5 amps
Set stall to 1.2 volts and 0.5 amps
Currently seems ok…………

Hey Avbates,

since on the Onefinity machines, Z home is on the topmost position, you do ➪ stall homing against gravity (➪ see also here). The effect only appears when stall homing. The heavier the weight of the Z carriage and the spindle, the more will stall homing fail. This is because when using stall homing, the controller tries to find out if the axis ceased to move, and it does this by sensing whether the stepper motor produces electro-motive force (i.e. acts as a generator), which it does only when moving. However it can sense this only when there flows no current. But when no current flows, you have no holding torque which means the stepper runs freely, which means, it does no more hold the carriage’s weight against gravity.

You could avoid this by ➪ retrofitting limit sensors instead of using the generally not accurate stall homing. The buildbotics-derived Onefinity and the Buildbotics controllers support the connection of limit sensors.

1 Like

Thanks
Your comments are interesting. As the z20 reaches the top to stall home, it fails and starts buzzing. By applying DOWNWARD pressure it stops buzzing and homes.

With a Makita router you shouldn’t be having an issue. My guess is you may have a bad wire somewhere that’s only making contact part of the time. When it works you are identifying the solution as changing the settings. When homing doesn’t work you are blaming the settings. It’s just a guess.

When I upgraded to the Z20 I had to tweet the settings a bit but I have a 3hp water cooled spindle. After dialing it in I’ve never had to touch them again.

1 Like

See my comment above, it’s almost like my Makita router is not heavy enough. I have checked my wiring, will check again
Definitely weight related. When it reaches the top, fails to home and starts buzzing, if I put my hand on the top of the router and push down it immediately stops and homes.
This happens at both 1 volt and 0.5 amps or at 2 volts and 1 amp.

Too light shouldn’t be an issue. Both the X and Y axis have almost no resistance and they home the same way. The more you lower the numbers the more likely it’ll think it’s reached home before it’s actually reached the axis’s limit. If the numbers are too high it’ll just reach the limit of the axis and try even harder to continue moving further because the controller is waiting until the current goes above the number you set.

1 Like

Hey Avbates,

there was a user that mounted the Onefinity vertically but not the right way. I would have home at the top so stall homing against gravity didn’t work. After assigning the axis to their reversed direction, home was again at the lower position and stall homing worked. However, you can’t do that with the Z axis since you need to have Z home at the topmost position, because if it was on the lowest position you may inadvertendly drill a hole into your wasteboard depending on tool length. So the only ways to solve this issue are the five solutions linked in the link in my post above (you click on my links, do you?).