Fusion 360 CAM Setup NOOB Thread

Alright, I am still wrestling with my machine and mostly due to Fusion 360. So I have some questions here that I feel like they’ve been answered in the forum, but I simply cannot find the info I’m looking for. Im not new to CAD, but I certainly new to CAM software, and that is where much of my trouble resides.

I’ve researched the tutorials and youtube videos, but these are the questions I have yet to find answers for. Hoping this thread can help others down the line as well.

  1. Post processor —
    I see that there is a onefinity post-processor (possibly 2) we can download, or a buildbotics post-processor built into F360 that folks are talking about. Do folks recommend one over the other?

  2. Machine —
    I know folks are using “Generic 3-axis” but at least in the mac side of things (unless there has been a recent update) the generic 3 axis category has 6 options based on configuration. I’m assuming folks are using the “YXZ Axis on the head” option? Thats the closest option I can find to the onefinity.

  3. Machine Configuration —
    Apart from the envelope of the machine, are there any settings I need to adjust in the actual machine configuration in F360? There are fields under capabilities, kinematics, and multi-axis that i havent a clue how to set. Do I need to bother?

1 Like

Machine: I use @blaghislain machine settings (but you can do your own easily enough; I set the machine dimensions and return position. The former F360 checks and gives warnings, and the latter I use to stop the router returning to 0,0 only for me to jog out the way to change bits

PostProcessor: again, I use @blaghislain post-processor. Works great for spindle or router.

They can be found here: onefinity-post-processors/README.md at main · blaghislain/onefinity-post-processors · GitHub.

It is easy to lose your way in all the forum threads.

Good luck - first cuts are always nervy. I still have my finger hovering over the square stop button when I fire up a new run.

2 Likes

This is PRECISELY the kind of info I was looking for. Gonna have to dive into this tonight or tomorrow. Thanks!

When you’re up to speed you might want to try putting a pause/dwell in your gcode at the start (I use 10 seconds). I find, for me at least, that it gives me that forced concentrated period to scan everything is ok (e.g. no spanners on the wasteboard, get finger poised), before the 1F makes a dive. I should scan before I start but hey hum, I can forget sometimes.

3 Likes

I am having almost same the issue; struggling with generating G Codes in F360. I am not only new to practical CNC but also a novice with CAD. I overcame CAD problem by watching Arnold Rowntree’s 16 part beginner series on YouTube. Now I can at least do some basic and simple designs.
So, I created a simple design consisting of a 5 mm thick border of 90 x 60 mm size. And in the middle I have my initials. Border and letters are 2 mm raised.
I installed the Onefinity postprocessor successfully as mentioned here in this forum. However, when I try to generate G Codes using that post processor, an error comes up saying no operation was selected. And I do not see any operation listed on the Operations tab. It looks like that I am missing a required step before generating the G Codes. So, here I am seeking and requesting some guidance.
Thanks,
kr

You have to create a toolpath and then select it before posting.

Ok, so that is what I am missing. Thanks.
I know asking people here to teach me the details of toolpath creation in F360 will not be nice. So, please point me to some resources, like YouTube or other places on the internet where I can learn this specific topic, that is how to create toolpath in F360?
I appreciate any and all help.
Thanks,
kr

1 Like

No issues from my perspective with asking for help. I’ll gladly spend 10 minutes with you on a zoom if you aren’t able to figure it out.

For my money Lars has got the best Fusion tutorials on YouTube.

2 Likes

That is a great offer. I will save it for the future at this time :slight_smile:
I just checked the link you mentioned and watched for a few minutes. That seems very useful. Thanks a bunch. I will watch the video tomorrow and provide my feedback.
kr

I just tried loading the post processor and I get an “invalid post processor” error. :man_shrugging:t4:

Anyone else have this problem?

I think I found the issue. Seems that with the latest update, when it was saved as a .cps, it accidentally included the whole webpage in there too. Fusion 360 does not like that.

I tried updating and saving — but it is locked.
And I tried creating a new text file and saved with a .cps extension — but that isnt being recognized as a valid .cps

Looks like the machine files have the same issue.

@blaghislain are you able to update the files?

Otherwise, what program do we need to properly create and save a .cps file?

I may have been doing something wrong. But I downloaded all with the provided link on github rather than right-click save link as on individual files. That provided clean files.

The file is ok for me

  1. Downloaded using this link https://github.com/blaghislain/onefinity-post-processors/blob/main/Fusion/onefinity_fusion360.cps
  2. clicked this
  3. Opened file editor (filename: onefinity_fusion360.cps) on your pc
  4. pasted clip-board content.
  5. Saved the file (test was ok)

Yeah. So my first problem was I attempted to “save” the file by right-click “save link as”…

Just now I attempted to follow your instructions.
I used my text editor program, pasted, and saved the file as a .cps extension.
(I’m on a mac BTW in case that’s an issue)

But Fusion360 wouldnt recognize the file as a valid .cps file, so I couldnt even select it as an option.
Perhaps I needed to save it with a software compiler? (I dont have one installed)

In either case, I used the “download all files” link on github to download the .zip file.
Those files worked without a problem.

Interesting. Happy that if finally work. Tomorrow I Will try to see if there is a way to add a release or package file so direct download will work. Will need you collaboration to give it a test.

no problem. happy to help.

Please give it a try using the file link under assets. Thanks
blaghislain/onefinity-post-processors

Yup! Works well on my end!

1 Like

This thread is scaring the p**p out of me. I have a Journeyman coming in a few weeks and I didn’t understand half of what I just read! What have I gotten myself into?? hahaha

2 Likes

I too am waiting on my Journeyman.
Happy to help you with the setup in Fusion if you have questions.

Once you setup your workflow it is a lot of repetitive clicks!

1 Like